New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


PTFWinCertExpiration not finding cert

Votes:

0

Your Vote:

Up

Down

Based on the responses in several threads here, I downloaded and installed the PTFWinCertExpiration custom sensor. From Command line, it works PERFECT, returning the right number of days, however when I pass the parameters to the sensor in the web-interface, it fails. (I've copy and pasted, and manually typed both, to check for any accidental garbling)

I do notice that the only Primary Channels I see as options are Downtime and Execution Time, Value, as noted in the documentation, is not a choice.

Am I missing anything obvious? :(

For the record, this is for a code signing certificate, not a web cert, if that matters.

certificate prtg ptf

Created on Aug 4, 2016 9:24:41 PM by  raubrey (0) 1

Last change on Aug 5, 2016 8:44:15 AM by  Luciano Lingnau [Paessler Support]



2 Replies

Accepted Answer

Votes:

0

Your Vote:

Up

Down

Hello raubrey,
thank you for your KB-post.

What exact error message do you get in the sensor within PRTG? Please note that it's possible to configure the "Write result to disk" option within the sensor's settings, this will generate a file with the actual output/error in the following path of the probe were the sensor was deployed:

C:\ProgramData\Paessler\PRTG Network Monitor\Logs (Sensors)\

Since you've mentioned that the sensor works from the command-line but doesn't work in PRTG this sounds very much like an account/permission/impersonation issue. Which parameters did you configure in the sensor's settings? It should look like this:

-h=%host -t=THUMBPRINT -u=%windowsdomain\%windowsuser -p=%windowspassword

This way PRTG will replace this parameters as defined in the parent object (or inherited), make sure that in PRTG the Device's Address is correct and that the Credentials for Windows Systems are correct (or are correctly inherited).

It may be able to run the sensor without providing an username and password as parameter if you use the security context of probe service and run the PRTG Probe Service with account allowed to log-in both on the probe and remote system. The default Local System account will most likely not have this privilege.


Best Regards,
Luciano Lingnau [Paessler Support]

Created on Aug 5, 2016 9:01:46 AM by  Luciano Lingnau [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Luciano, Thank you for the quick reply! I was hoping to get around passing credentials, but then I realized that since the cert is in the Trusted Publisher store, I can check locally instead of having to pass around. Changing the server I pointed to allowed me to drop the credentials and it's all happy now. Thanks for helping me get the last piece of the puzzle together! :)

Created on Aug 5, 2016 2:11:29 PM by  raubrey (0) 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.