New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


File sensor age does not work well when in alarm

Votes:

0

Your Vote:

Up

Down

I have setup a file sensor, which is working good, it is set for files older than 2 days has to give a alarm or warning.

When its going into warning, everthing is going well, but when I change the setting to go in alarm instead of warning, then its not giving me any data anymore, also not in the mail.

See the images below

When in Warning + Settings: Warning View

Warning Settings

When in Alarm + Settings: Error View

Error Settings

age alarm filesensor warning

Created on Aug 22, 2016 7:41:49 AM by  rnijland (0) 1

Last change on Aug 22, 2016 1:13:02 PM by  Erhard Mikulik [Paessler Support]



5 Replies

Votes:

0

Your Vote:

Up

Down

Do you get something like "PE100" in the sensor's message and it does not show values anymore? At least that's what I observe in my tests, looks like a bug, I consult development about it.

Quick fix for you to get it working with error state: Set "Check File Ages" to "Do not check". Instead set a limit inside the channel "File Age" (click on the channel to enter its settings), select "Enable Limits" and set "Upper Error Limit" to 259200 which equals three days in seconds, because the channel originally measures file age in seconds. This will set the sensor to error when file age is greater than 259200 seconds (3 days). This has also the advantage that you can use different limits for warning AND error.

Kind regards.

Created on Aug 22, 2016 1:47:43 PM by  Erhard Mikulik [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Yes I get PE100 error.

Created on Aug 23, 2016 6:03:39 AM by  rnijland (0) 1



Votes:

0

Your Vote:

Up

Down

Ok, that's what I expected. Disable the check for file age in the sensor's "Settings" tab and set a limit as described my last reply directly in channel "File Age". This will work.

Kind regards.

Created on Aug 23, 2016 8:45:10 AM by  Erhard Mikulik [Paessler Support]



Votes:

0

Your Vote:

Up

Down

OK that will work.

But is it a bug and will it be fixed soon?

Created on Aug 23, 2016 10:17:32 AM by  rnijland (0) 1



Votes:

0

Your Vote:

Up

Down

More or less. It is currently being discussed whether we remove this option in the future so that it only works with the limits from the channel. The implemented logic in the sensor's settings seems to be more prone to erroneous behavior than working with the channel limit.

Kind regards.

Created on Aug 24, 2016 2:27:42 PM by  Erhard Mikulik [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.