New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Sensor proxy settings for HTTPS

Votes:

0

Your Vote:

Up

Down

Hi We have some http sensors for site monitoring via HTTP, these sensors connects to sites via proxy. Now we need to monitor the same sites via HTTPS, after changing url to HTTPS and setting SNI setting to "Do not inherit SNI from parent device" sensors give an error: "Connection reset by peer (socket error # 10054)". Sensor proxy settings should work for HTTPS requests?

https proxy prtg

Created on Sep 7, 2016 10:29:01 AM by  TDV (60) 1 1



6 Replies

Votes:

0

Your Vote:

Up

Down

This error messages indicates that the target devices requires sni, so please change the setting back to "Inherit SNI from parent device".

Created on Sep 7, 2016 2:49:19 PM by  Jochen Greger [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I tried to change setting back to "Inherit SNI from parent device" but it didnt help - sensor stayed in "down" state but without any error message. I think this is because of address of the parent device of the HTTP sensor doesnt match sensor url. Also if disable proxy in sensor setting - it works ok. Is there some problem in sensor settings or they are correct and problem in proxy server setting?

Created on Sep 7, 2016 3:11:29 PM by  TDV (60) 1 1



Votes:

0

Your Vote:

Up

Down

You can adjust the proxy configuration in the parent device settings in the section "PROXY SETTINGS FOR HTTP SENSORS ". If you afjust the parent device url to match the sensor url, does it work then?

Created on Sep 8, 2016 10:44:25 AM by  Jochen Greger [Paessler Support]



Votes:

0

Your Vote:

Up

Down

No - in this case sensor doesnt work too.

Created on Sep 8, 2016 11:03:35 AM by  TDV (60) 1 1



Votes:

0

Your Vote:

Up

Down

Please forward us some screenshot to "support@paessler.com" showing the parent device settings, the "Overview" and "Settings" tab of the https sensors in case. Please refer to this kb article.

Created on Sep 9, 2016 1:12:44 PM by  Jochen Greger [Paessler Support]

Last change on Sep 12, 2016 11:25:35 AM by  Jochen Greger [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi, It seems that this is proxy server problem not prtg. Thanks

Created on Sep 12, 2016 8:35:16 AM by  TDV (60) 1 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.