New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


80070005: Access is denied Custom WMI - local accounts - few machines

Votes:

2

Your Vote:

Up

Down

Hello,

I'm using custom WMI sensor: SELECT ActiveSessions FROM Win32_PerfFormattedData_LocalSessionManager_TerminalServices

So far it worked instantly on 7 VMs but it failed on two.

What I did: Allow in windows firewall 3 rules for certain local IP address: Windows Management Instrumentation(WMI-In) Allowed - Inbound Rule Windows Management Instrumentation(DCOM-In) Allowed - Inbound Rule Windows Management Instrumentation(ASync-In) Allowed - Inbound Rule

And it worked like a charm but not for last VM.

I have tested WMI by using paessler WMI tester and it's the same error.

Checked out on that VM:

Permission for the user to the WMI namespace - local admin has all rights Verify WMI Impersonation Rights - local admins has all rights DCOM permission - ensured launch and activation permissions for "Everyone" user group has "Local Activation" and "Local Launch" permission. Credentials are correct. Turned off Windows Firewall completely and issue persisted.

Any help is welcome. Thank You

access-denied local-probe prtg wmi

Created on Oct 6, 2016 8:06:37 AM by  Vedran (12) 1



3 Replies

Votes:

1

Your Vote:

Up

Down

winrm quickconfig Run is from cmd as admin and it will solve all issues. Helped to me.

Created on Oct 6, 2016 9:32:55 AM by  Vedran (12) 1



Votes:

0

Your Vote:

Up

Down

Hello,

We are glad that you were able to solve the issue by yourself. Also thank you for providing the solution for other users. :)

Created on Oct 6, 2016 11:23:45 AM by  Dariusz Gorka [Paessler Support]



Votes:

0

Your Vote:

Up

Down

FYI: This fix worked for me as well.

Ours worked fine when using the local Administrator account. We created a new user so that we did not have to use the local Administrator account. The sensors failed when configured to use the new user, even if that new user was a member of the local Administrators group. After applying the fix, WMI Tester now shows successful connections.

Created on Jan 31, 2019 8:56:02 PM by  stanmat (129) 3 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.