New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


WMI Sensor: RPC unavailable - exchange 2013

Votes:

0

Your Vote:

Up

Down

Cannot get any WMI sensor to RPC to an Exchange 2013 server. I've checked everything down through nmap, wireshark and procmon and verified there is complete and consistent network connectivity to the server over port 135.

Interestingly there are only two RPC related processes I see in procmon on the Exchange 2013 server:

1.) Microsoft.Exchange.RpcClientAccess.Service.exe -> QueryOpen ->C:\Program Files\Microsoft\Exchange Server\V14\Bin\Microsoft.Exchange.RpcClientAccess.Service.exe.config SUCCESS

2.) store.exe -> RegQueryValue ->HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\RPC Retry Count NAMENOTFOUND

Since both of these are Exchange related RPC, I've tried mail server specific WMI Sensors and still got PE015 RPC unavailable. This is a multi-domain environment and there are plenty of other servers with WMI sensors in this domain working OK, this is specific to my Exchange server.

Not sure where else to look, I've been through ALL the RPC related error documentation and tried it all. I'm stuck.

exchange-2013 pe015 wmi

Created on Oct 18, 2016 5:35:10 PM by  houlihas (100) 1 2



3 Replies

Votes:

0

Your Vote:

Up

Down

Hello,

If the Exchange server belongs to a different domain than the probe, then please enter the according domain administrator credentials of the Exchange server's domain into the device settings. Additionally, please have a look at the following site which describes the monitoring of servers outside of the PRTG server's domain: https://kb.paessler.com/en/topic/203.

Created on Oct 19, 2016 11:29:31 AM by  Dariusz Gorka [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I've added the monitoring account both locally and in either domain of both servers with the same username password.. verified remote management, changed the PRTG probe service logon account.. the firewalls are completely turned off and I see the RPC connection in Resource Monitor.. but somehow I'm still getting error 800706BA.

Again, this is only happening to my Exchange 2013 DAG cluster servers, where every other server in the other domain has WMI sensors running normally with no problems.

The only common denominator here really seems like Exchange 2013. Not sure what else to try and this is highly frustrating as it's a critical sensor for us and I've spent way too much time on it already.. looking at Nagios.

-sMh-

Created on Oct 24, 2016 1:39:55 PM by  houlihas (100) 1 2



Votes:

0

Your Vote:

Up

Down

Hello, please check all things listed on the following page under "800706BA - RPC Server Is Unavailable": https://kb.paessler.com/en/topic/1073

Created on Oct 25, 2016 7:25:38 AM by  Dariusz Gorka [Paessler Support]

Last change on Oct 25, 2016 7:25:48 AM by  Dariusz Gorka [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.