New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Auto-discovery AD integration issue

Votes:

0

Your Vote:

Up

Down

I'm trying to configure Auto-Discovery to use AD integration (filtered by OU) but receive the following error:

Error (Bad Request) The validation of at least one of the new objects failed because of the following: Active Directory cannot be accessed for "IP Selection" (Auto discovery setting)

The discovery works fine if I leave the OU field empty. I'm trying to use:

OU=Servers,OU=Infra,DC=removed,DC=removed,DC=removed,DC=removed (this is the distinguisedName field in AD)

The full error given is:

Version: 16.4.27.6720 Server: <removed> URL: addgroup2.htm?id=1&name_=Group+1&tags_=&discoverytype_=1&devicetemplate_=1&devicetemplate_=1&discoveryschedule_=0&ipselectmethod_=5&ipbase_=&iprangebegin_=1&iprangeend_=254&iplist_=&ipsubnet_=&ipoctetrange_=&iplistv6_=&ipou_=OU=Servers,OU=Infra,DC=....,DC=....,DC=..,DC=..&usedns_=1&skipknownips_=1&windowsconnection=0&windowsconnection=1&windowslogindomain_=&windowsloginusername_=&windowsloginpassword_=&linuxconnection=0&linuxconnection=1&linuxloginusername_=&linuxloginmode_=0&linuxloginpassword_=&privatekey_=&wbemprotocol_=https&wbemportmode_=0&wbemport_=5989&sshport_=22&sshelevatedrights_=1&elevationnamesudo_=&elevationnamesu_=&elevationpass_=&sshversion_devicegroup_=2&vmwareconnection=0&vmwareconnection=1&esxuser_=&esxpassword_=&esxprotocol_=0&vmwaresessionpool_=1&dbcredentials=0&dbcredentials=1&usedbcustomport_=0&dbport_=&dbauth_=0&dbuser_=&dbpassword_=&dbtimeout_=60&cloudcredentials=0&cloudcredentials=1&awsak_=&awssk_=&snmpversiongroup=0&snmpversiongroup=1&snmpversion_=V2&snmpcommv1_=public&snmpcommv2_=public&snmpauthmode_=authpHMACMD596&snmpuser_=&snmpauthpass_=&snmpencmode_=DESPrivProtocol&snmpencpass_=&snmpcontext_=&snmpport_=161&snmptimeout_=5&httpproxy=0&httpproxy=1&proxy_=&proxyport_=8080&proxyuser_=&proxypassword_=&accessgroup=0&accessgroup=1&accessrights_=1&accessrights_=1&accessrights_2614=-1&accessrights_2976=-1&accessrights_2533=-1&accessrights_2419=-1&accessrights_2416=-1&accessrights_2493=-1&accessrights_3492=-1&accessrights_201=-1&accessrights_2412=-1

Anyone know how to get past this?

active-directory auto-discovery prtg

Created on Nov 14, 2016 11:19:13 AM by  richs (0) 1



11 Replies

Accepted Answer

Votes:

0

Your Vote:

Up

Down

The correct one would be: Servers,OU=Infra,DC=removed,DC=removed,DC=removed,DC=removed

The OU for the first OU has to be removed, PRTG will find it automatically then. If it doesn't work as well, please also omit all DC items from the string (i.e. only Servers,OU=Infra).

Created on Nov 16, 2016 1:12:34 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Worked a treat, thanks.

Created on Nov 21, 2016 7:59:50 AM by  richs (0) 1



Votes:

0

Your Vote:

Up

Down

I don't know if it's OK for me to addon to this with the same problem...

We have a situation where the core server is in one domain (contoso.com) and I'm trying to setup a remote probe in another domain (fabrikam.com). However, auto-discovery doesn't work when I specify the OU, using the above syntax. I get the error: •Active Directory cannot be accessed for "IP Selection" (Auto discovery setting)

I've tried both: A,DC=fabrikam,DC=com and A

I have credentials set for Windows Systems in the Remote Probe settings, using my own admin account for testing, which has domain admin rights for fabrikam.com

Is this scenario perhaps not supported by PRTG?

Created on Jan 18, 2017 10:14:15 PM by  Peter Bollwerk (80) 1 1



Votes:

0

Your Vote:

Up

Down

I'll talk with the developer and let you know what he said :)

Created on Jan 19, 2017 1:29:56 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Could you try

A,DC=fabrikam

...without DC=COM at the end?

Created on Jan 19, 2017 1:33:01 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Same error without DC=com at the end. =(

Created on Jan 19, 2017 10:23:23 PM by  Peter Bollwerk (80) 1 1



Votes:

0

Your Vote:

Up

Down

Hm. How about A,DC=fabrikam.com?

Created on Jan 23, 2017 9:12:07 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

A,DC=fabrikam.com also does not work. Same error. =(

Created on Jan 23, 2017 6:39:47 PM by  Peter Bollwerk (80) 1 1



Votes:

0

Your Vote:

Up

Down

Is your PRTG webinterface available from outside of your network?
Feel free to post the credentials,I won't publish it. Then I can check it out :)

Created on Jan 23, 2017 7:43:12 PM by  Stephan Linke [Paessler Support]

Last change on Jan 23, 2017 7:43:37 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Our security policies don't permit sharing passwords. Can we setup a screen sharing session perhaps?

Created on Jan 23, 2017 8:53:14 PM by  Peter Bollwerk (80) 1 1



Votes:

0

Your Vote:

Up

Down

Sure. Please open up a ticket with [email protected] and state your time zone + the times when your available within the same :)

Created on Jan 23, 2017 8:59:49 PM by  Stephan Linke [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.