New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


SNMPERR_BAD_ASN1_BUILD (SNMP error # -11)

Votes:

0

Your Vote:

Up

Down

Hi, I'm trying to add a traffic sensor to monitor the bandwidth used in a couple of ports in a switch. When I run the Test with the Paessler SNMP Tester, with the OID needed, I get :

Paessler SNMP Tester 5.2.3 Computername: JAPON Interface: 192.168.0.171
27/12/2016 9:59:56 (10 ms) : Device: 192.168.0.248
27/12/2016 9:59:56 (14 ms) : SNMP V2c
27/12/2016 9:59:56 (19 ms) : Custom OID 1.3.6.1.2.1.1.3.0
27/12/2016 9:59:56 (29 ms) : SNMP Datatype: ASN_TIMETICKS
27/12/2016 9:59:56 (34 ms) : -------
27/12/2016 9:59:56 (38 ms) : Value: 146053400
27/12/2016 9:59:56 (43 ms) : Done

If I read the uptime device I get:

Paessler SNMP Tester 5.2.3 Computername: JAPON Interface: 192.168.0.171
27/12/2016 10:18:36 (37 ms) : Device: 192.168.0.248
27/12/2016 10:18:36 (42 ms) : SNMP V2c
27/12/2016 10:18:36 (48 ms) : Uptime
27/12/2016 10:18:36 (58 ms) : SNMP Datatype: ASN_TIMETICKS
27/12/2016 10:18:36 (63 ms) : -------
27/12/2016 10:18:36 (77 ms) : DISMAN-EVENT-MIB::sysUpTimeInstance = 146165800 ( 16 days )
27/12/2016 10:18:36 (97 ms) : SNMP Datatype: SNMP_EXCEPTION_NOSUCHOBJECT
27/12/2016 10:18:36 (107 ms) : HOST-RESOURCES-MIB::hrSystemUptime.0 = No such object (SNMP error # 222) ( 0 seconds )
27/12/2016 10:18:36 (118 ms) : Done

I think I am receiving data via SNMP, but when I try to add the sensor, I get the message "SNMPERR_BAD_ASN1_BUILD (SNMP error # -11)"

I am using the same community string in both softwares (PRTG and SNMP Tester).

Can you help me to solve this issue?

Thank you.

Regards, Pablo Verón.

error snmp test

Created on Dec 27, 2016 1:23:50 PM by  pveron23 (0) 1

Last change on Dec 28, 2016 11:10:18 AM by  Luciano Lingnau [Paessler Support]



1 Reply

Votes:

0

Your Vote:

Up

Down

Hello Pablo,
thank you for your KB-Post.

Your troubleshooting steps are correct, the sensor should be working since the SNMP Tester does get a valid reply. Please confirm, does an "SNMP Custom" sensor deployed on this OID work?

1.3.6.1.2.1.1.3.0

The SNMPERR_BAD_ASN1_BUILD (SNMP error # -11) is an underlying error caused by the SNMP Components. Which PRTG version are you running? Please update your PRTG deployment to the latest available version (this can be done via auto-update) and let us know whenever the issue persists after the update.

Best Regards,
Luciano Lingnau [Paessler Support]

Created on Dec 28, 2016 11:10:02 AM by  Luciano Lingnau [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.