What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

SQLv2 sensor stopped working

Votes:

0

Your Vote:

Up

Down

Hi, We´ve migrated succesfully to the SQLv2 sensors, but one day after the migration all the sensors stopped working with the error:

Could not load file or assembly 'Paessler.Xml, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified

i've tried searching but i cannot find any answer related, all other sensors like ping, ssl, http worked fine, just the sqlv2 sensor stopped, I tried find this Paessler.xml file on internet or the prtg core server but i cannot found it, and the sensor worked for 1 day, i cannot understand what happened.

thanks in advanced.

sensor sql sql-v2

Created on Jan 6, 2017 3:00:39 PM by  isabelr182 (0) 1



5 Replies

Votes:

0

Your Vote:

Up

Down

Hello,

Thank you very much for your KB-Post. May I ask, which exact PRTG Version are you running? And can you please share a screenshot showing the full settings of this very SQL v2 Sensor?

Thank you!

Created on Jan 9, 2017 9:50:27 AM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Thanks for your answer! My PRTG Version PRTG Network Monitor 16.4.28.7421 x64

This is my configuration:

https://i.imgsafe.org/6445d144b2.png https://i.imgsafe.org/6445f1e900.png

It seems like the sensor works some times:

https://i.imgsafe.org/649a94a34c.png

Thanks in advance

Created on Jan 11, 2017 3:12:10 PM by  isabelr182 (0) 1



Votes:

0

Your Vote:

Up

Down

Thank you for the response and the screenshots. I checked with our devs, the error suggests, that the "Paessler.Xml.dll" is missing in the "Sensor System" subfolder of the PRTG Program files directory. A simple reinstall will fix this.

Created on Jan 12, 2017 12:24:24 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

HI! I already reinstall and the error is the same, i checked the folder you suggest and the file is there

https://i.imgsafe.org/78d51252e6.png

i think since the error is intermitent it should another thing but i dont know where to check.

thanks!

Created on Jan 12, 2017 2:08:14 PM by  isabelr182 (0) 1



Votes:

0

Your Vote:

Up

Down

It could be a Anti-Virus-Application causing troubles here? Is one installed? If yes:

  • Which one is installed and running?
  • Did you already check the logs from the Anti-Virus application?

Can you also try executing the "SQLv.exe" from the "\Sensorsystem"-subfolder of your PRTG Program Files directory. This is actually the sensor executable, it will open a GUI, and you can just click on "RUN" (when the sensor throws the error), without filling the fields. What happens then?

Created on Jan 12, 2017 3:46:18 PM by  Torsten Lindner [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.