What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

LimitMode not getting set on first channel read



I have a channel which should have a error and warning limit. To activate this, I have to send all the necessary information with the first data notification.

This is how my data JSON looks like: [{ "sensorid": "2276", "message": "This is a measurement", "channel": [{ "name": "MeasureCount", "mode": "integer", "unit": "Custom", "customunit": "MeasureCount", "value": 2, "LimitMode":1, "LimitMaxWarning":13, "LimitMinWarning":0, "LimitMaxError":25, "LimitMinError":-10, "LimitErrorMsg":"This is an error", "LimitErrorWarning":"Warning" } ] } ]

According the mini probe api documentation, this should activate the limit mode for this channel on the first notification. I do receive the value I my channel, but the LimitMode is not getting turned on nor the limit min and max settings are getting set. Why could this be? I couldn't find any other information why this would not work like that.

Thanks for your help

limits mini-probe prtg

Created on Feb 9, 2017 12:35:17 PM

Last change on Feb 10, 2017 10:10:10 AM by  Stephan Linke [Paessler Support]

1 Reply



Limits given via result are only applied upon sensor creation, not during runtime.
Where did you get the information (so we can fix it)? :)

Created on Feb 10, 2017 11:12:11 AM by  Stephan Linke [Paessler Support]

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.