New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


SNMP traffice sensor:Interface Number changed

Votes:

0

Your Vote:

Up

Down

Dear Sir, I have encountered the following condition. After a certain Linux machine reboot,the correspond sensor on PRTG trun into fail. I have checked the reason caused failure is that Network Interface Number changed while system reboot.

Here is my problem. I have turn on SNMP COMPATIBILITY OPTIONS into automatic. However, Interface number didn't update after that linux reboot. Could you help me fix this?

automatic interface-number snmp-traffice-sensor

Created on Mar 15, 2017 10:50:14 AM by  sunmuel (0) 1



11 Replies

Votes:

0

Your Vote:

Up

Down

Can you post screenshots of the old and new sensors' settings? Does that happen on every reboot?

Created on Mar 16, 2017 1:48:40 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Old Sensor: https://drive.google.com/open?id=0B7CGp4LHFVS5OHRhODl5WFNvdlE

New Sensor: https://drive.google.com/open?id=0B7CGp4LHFVS5cTFnY2REYk9zOGM

The system offer B2B Service, this is the first time to reboot, so we have no log before to compare with them.

thanks

Created on Mar 20, 2017 12:18:09 AM by  sunmuel (0) 1



Votes:

0

Your Vote:

Up

Down

You could try to click the small lock and change the number from 2 to 4 and see if that makes the sensor go again. That's the only way to handle changing interfaces :)

Created on Mar 20, 2017 7:08:36 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Dear Sir: By your instruction,we are not able to edit the field when I click small lock. The following message pops up: "Only edit this field when asked to do so by the Paessler support team. Unauthorized use can lead to false monitoring data." How could I handle this problem? Thank you.

Created on Mar 20, 2017 9:24:17 AM by  sunmuel (0) 1



Votes:

0

Your Vote:

Up

Down

Please click [Ok] as it will unlock the field, making it editable.

Created on Mar 20, 2017 9:34:34 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I have encounter this issue also but each time a reboot, the interface number will change and i got to edit it, then it will be ok. So how can i make the auto detect the interface number only, so after each reboot, i don't have to change the interface number manually.

here is the screenshot:-

https://ufile.io/syfz6

Created on Nov 29, 2017 2:22:11 AM by  edmondyjh (0)



Votes:

0

Your Vote:

Up

Down

You need to enable ifIndex persistency in order to avoid the OID change for interfaces upon reboots.


Kind regards,
Stephan Linke, Tech Support Team

Created on Nov 29, 2017 9:01:49 AM by  Stephan Linke [Paessler Support]

Last change on Nov 29, 2017 9:01:57 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

so the ifIndex persistency needed to be set on to my device or prtg spftware? cause i can't find any of those command in the mikrotik device itself.

Created on Dec 7, 2017 9:49:45 AM by  edmondyjh (0)



Votes:

0

Your Vote:

Up

Down

This needs to be configured on the Mikrotik appliance. You may want to get in touch with their support to get this resolved, maybe they know how to configure it properly :)


Kind regards,
Stephan Linke, Tech Support Team

Created on Dec 7, 2017 11:19:04 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I have similar problem on Linux with net-snmp server. Every time the OpenVPN client reconnects, the index of the corresponding tap0 interface is increased by one. For example the sensor's Interface number was 5:tap0 when I've created it. And I have to change it to 6:tap0, 7:tap0, etc. every time when the OpenVPN connection is restarted. Moreover, when my whole server restarts it goes back to 5:tap0.

Basically the SNMP Traffic sensor is unusable in this situation beacuse it needs constant manual intervention.

I've tried to change the SNMP Compatibility option "Port Identification" to "Use ifName" but it doesn't solved the problem.

Is there any script or trick to automatically update the sensor number in PRTG based on the SNMP interface name?

Created on Sep 6, 2018 7:34:38 PM by  csadam (0) 1



Votes:

0

Your Vote:

Up

Down

Hi there,

Are the ifNames of your device unique? I recommend to configure unique ifAlias for the interfaces. Switch the port identification to ifAlias.

Please use the SNMP Tester from the probe host and perform a Scan Interfaces. Enter the correct IP address and SNMP community name so that the Tester is able to establish a connection. Use SNMPv2 and copy the results into a text file and attach it to your answer (if SNMPv2 does not work, also try SNMPv1).

Perform this scan once before the index changes and one more time afterwards. This will help us to see which settings persist and which settings changed.


Kind regards,
Felix Saure, Tech Support Team

Created on Sep 7, 2018 2:46:23 PM by  Felix Saure [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.