New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


PTRG Mails includes internal Port, instead of external URL

Votes:

0

Your Vote:

Up

Down

We are using PRTG behind an Apache Reverse Proxy and can only access the WebUI using the Proxy URL. The SSL Tunnel terminates on the Proxy.

External Proxy URL:https://monitor.domain.com
Internal PRTG URL:http://monitor.domain.com:8080

The PRTG generated Mails are only linking to the internal URL using the custom HTTP Port 8080, which will not work.

Where can I change it, so that the Links in Mails are pointing to the External URL?

emails prtg reverse-proxy

Created on May 4, 2017 10:32:08 AM by  netzgoetter (0) 1

Last change on May 4, 2017 10:59:53 AM by  Luciano Lingnau [Paessler Support]



Best Answer

Accepted Answer

Votes:

0

Your Vote:

Up

Down

Hello and thank you for your swift reply.

Ok, in that case the suggested approach won't work. Since there's no "real" way to set the port used in links generated by PRTG, you won't be able to effectively resolve this, but you can implement some workarounds.

For instance, if you're worried about alert/notification E-mails, you can define any custom content if you switch to "Text with custom content" alerts. You can then manually create the links in your E-mail. For instance for a link to the sensor:

https://monitor.domain.com/sensor.htm?id=%sensorid

More details about placeholders are available here:

For HTML E-mails, changes to the content are not officially supported. But you could modify the files in this folder to customize HTML E-mails:

C:\Program Files (x86)\PRTG Network Monitor\webroot\mailtemplates

Keep in mind that PRTG updates will automatically overwrite these files, so you may want to back-them-up before updating, otherwise you'll lose the changes when when you update. And keep in mind that this change is not officially supported.

Best Regards,
Luciano Lingnau [Paessler Support]

Created on May 4, 2017 11:57:03 AM by  Luciano Lingnau [Paessler Support]



5 Replies

Votes:

0

Your Vote:

Up

Down

Hello there,
thank you for your post.

You should use the same internal/external port, this way the URL will be right in both cases. While you can modify the DNS name under Setup > User Interface it is not possible to modify the port, PRTG will automatically use/append the port it is configured to run on.

Best Regards,
Luciano Lingnau [Paessler Support]

Created on May 4, 2017 11:05:55 AM by  Luciano Lingnau [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I already changed the DNS name under Setup > User Interface and the WebUI is working very well.

To only use the same Port will not work, because:

  • First of all the External URL is HTTPS not HTTP. The generated Links in Mails are using http://.... Links instead of HTTPS.
  • Second the Proxy and PRTG are running on the same machine. So the Port is being used already by the Proxy.

Created on May 4, 2017 11:19:28 AM by  netzgoetter (0) 1

Last change on May 4, 2017 11:45:35 AM by  Luciano Lingnau [Paessler Support]



Accepted Answer

Votes:

0

Your Vote:

Up

Down

Hello and thank you for your swift reply.

Ok, in that case the suggested approach won't work. Since there's no "real" way to set the port used in links generated by PRTG, you won't be able to effectively resolve this, but you can implement some workarounds.

For instance, if you're worried about alert/notification E-mails, you can define any custom content if you switch to "Text with custom content" alerts. You can then manually create the links in your E-mail. For instance for a link to the sensor:

https://monitor.domain.com/sensor.htm?id=%sensorid

More details about placeholders are available here:

For HTML E-mails, changes to the content are not officially supported. But you could modify the files in this folder to customize HTML E-mails:

C:\Program Files (x86)\PRTG Network Monitor\webroot\mailtemplates

Keep in mind that PRTG updates will automatically overwrite these files, so you may want to back-them-up before updating, otherwise you'll lose the changes when when you update. And keep in mind that this change is not officially supported.

Best Regards,
Luciano Lingnau [Paessler Support]

Created on May 4, 2017 11:57:03 AM by  Luciano Lingnau [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Thank you for your quick answers.

So I need to walk through the mail templates and change it there.

Can you add a feature request for me, please?

It would be fine to define and add a configuration parameter for an External URL (https://monitor.domain.com/...) used for Links in Mails or generated Links.

Created on May 4, 2017 12:45:47 PM by  netzgoetter (0) 1



Votes:

0

Your Vote:

Up

Down

Hello, thank you for your reply.

I will take note of your request. However, I'm unable to guarantee that it will be implemented anytime soon. As there are very little requests for this and a workaround is possible, the priority of the request is not very large. Please read this KB-Post to understand how we rate and prioritize feature requests:

Best Regards,
Luciano Lingnau [Paessler Support]

Created on May 11, 2017 7:50:07 AM by  Luciano Lingnau [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.