New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


How to monitor SSL certificate for self signed for linux server using "SSL Certificate Sensor"

Votes:

0

Your Vote:

Up

Down

Hello,

I am trying to monitor SSL certificate for self signed for linux server using "SSL Certificate Sensor".

Failed to establish secure connection [Step 0] Socket Error # 10060 Connection timed out. [Step 1] Socket Error # 10060 Connection timed out. [Step 2] Socket Error # 10060 Connection timed out. [Step 3] Socket Error # 10060 Connection timed out. [Step 4] Socket Error # 10060 Connection timed out. [Step 5] Socket Error # 10060 Connection timed out.

However, it worked for the other server without any issues.

The certificate is self-signed. Basically I want to show Days of Expiration.

How can this be achieved in PRTG ???

self-signed-certificate socket-error ssl-certificate

Created on Nov 28, 2017 12:24:22 PM by  ramkumarj (60) 1 1



5 Replies

Votes:

0

Your Vote:

Up

Down

Hi there,

Please make sure that you have entered the FQDN/Domain in the device settings and the same Domain in the sensor settings. The sensor always connects against the device connection IP/DNS-Name and checks the entered SNI in the sensor settings. If unsure, please write the entered device IP/DNS-Name and the sensor settings "SNI-Option" down here so we can check if they will work.

Best regards.

Created on Nov 29, 2017 8:49:14 AM by  Dariusz Gorka [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello,

SSL Certificate Specific Port : 443 Virtual Host (SNI Domain): ftp.test.com Certificate Name Validation: Do not compare common name with device address or SNI (default) Connection Specific: Do not use SOCKS proxy (default)

When I add it I am getting this error:

Failed to establish secure connection [Step 0] Socket Error # 10060 Connection timed out. [Step 1] Socket Error # 10060 Connection timed out. [Step 2] Socket Error # 10060 Connection timed out. [Step 3] Socket Error # 10060 Connection timed out. [Step 4] Socket Error # 10060 Connection timed out. [Step 5] Socket Error # 10060 Connection timed out.

Created on Nov 29, 2017 10:25:01 AM by  ramkumarj (60) 1 1



Votes:

0

Your Vote:

Up

Down

Hi there,

The settings seem to be correct. What is the device's connection IP/DNS-Name?

Best regards.

Created on Nov 29, 2017 10:50:08 AM by  Dariusz Gorka [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello,

I am using following DNS-Name: ftp.allisptest.eu which is having the self-signed certificate and resolves to proper IP.

Thanks.

Created on Nov 29, 2017 10:54:20 AM by  ramkumarj (60) 1 1



Votes:

0

Your Vote:

Up

Down

Hi there,

Then this will not work as the entered SNI "ftp.test.com" is not correct. Please enter into the sensor settings the same FQDN you use in the device settings. So please change the SNI-Setting in the sensor settings to "ftp.allisptest.eu" instead. Does that work properly?

So:

  • Device Connection IP/DNS-Name: ftp.allisptest.eu
  • Sensor's SNI Setting: ftp.allisptest.eu

    Best regards.

Created on Nov 29, 2017 11:01:26 AM by  Dariusz Gorka [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.