New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


SSH on FreeNAS

Votes:

0

Your Vote:

Up

Down

I would like to use SSH sensor on FreeNAS. Seems like PRTG can't connect to FreeNAS (FreeBSD). Is there any way to use this type of sensors on FreeNAS (FreeBSD).

freebsd freenas prtg ssh

Created on Feb 16, 2018 10:18:53 AM by  Mata (0) 1



5 Replies

Votes:

0

Your Vote:

Up

Down

We can connect to linux hosts. It depends on the commands the linux variant will receive.

You can use our SSH Custom sensor to issue the commands that FreeNAS accepts.

Do you know what CLI commands FreeNAS accepts for things like CPU, RAM, Disk, etc..?

Created on Feb 17, 2018 4:40:05 AM by  Benjamin Day [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I have tried SSH Meminfo and SSH Disk Free. SSH Disk Free sensor works great. On SSH Meminfo I got error "The host's system is unable to process PRTG's command: "cat /proc/meminfo"", but this is also OK because FreeNAS doesn't support cat /proc/meminfo command. So I assume that PRTG can connect to FreeNAS using SSH. Problem is SSH Script Advanced. When I tried to add this sensor I've got "Warning: no access to tty (Bad file descriptor)." under the Script drop-down menu instead of name of scripts. You can check it here: https://imgur.com/a/Iz1H5. Scripts are located under /var/prtg/scriptsxml. I've tried even with root credentials. I'm using this type of sensor on Linux machines and it works as expected. Also, I haven't found that FreeNAS/FreeBSD is supported: https://kb.paessler.com/en/topic/6733-which-linux-or-mac-os-distributions-are-supported-by-the-linux-unix-sensors-ssh-snmp. So maybe this is the problem?

Created on Feb 22, 2018 2:51:47 PM by  Mata (0) 1



Votes:

0

Your Vote:

Up

Down

Mata,

Change the directory to "/var/prtg/scripts"

That's the directory which we are looking for your scripts to reside.

Created on Feb 27, 2018 6:27:10 PM by  Benjamin Day [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I have changed directory to "/var/prtg/scripts", but unfortunately, I got the same error.

Created on Mar 12, 2018 3:45:24 PM by  Mata (0) 1



Votes:

0

Your Vote:

Up

Down

Hello Mata,

Can you manually SSH into the device, independently of PRTG? Keep in mind the sensor relies on "Linux/Solaris/Mac OS (SSH/WBEM) systems" credentials that need to be configured in the device's "Settings" tab. It seems to be more or less an access restriction related to the credentials or how SSH is set up on FreeNas, when googling for "no access to tty (Bad file descriptor)", there's quite a lot to be found.

Kind regards,

Erhard

Created on Mar 13, 2018 3:10:34 PM by  Erhard Mikulik [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.