New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Problem with virtual machine sensor (SOAP)

Votes:

0

Your Vote:

Up

Down

when i try to add vm sensor (SOAP) on my vcenter server i get "sorry, the scan for available monitoring items has failed". adding the vm sensor on my ESX host works like a charm.

What am i missing ? .NET 4.7 is installed on the probe and the ESX credentials are verified

ESX and vSphere are version 6.0

thx in advance for any hints

esxi soap vcenter

Created on Feb 26, 2018 2:56:39 PM by  BABA (0) 1



4 Replies

Votes:

0

Your Vote:

Up

Down

Hi Baba,

Open a command line on the PRTG Probe Host and navigate to the directory "C:\Program Files (x86)\PRTG Network Monitor\Sensor System" to execute the command

C:\Program Files (x86)\PRTG Network Monitor\Sensor System>VMWareSensor.exe -l=host -s=10.0.0.96 -u=root -p=t***5 -debug=c:\temp

Replace the address, user and password; if you directly scan the vCenter, you can keep the -l=host parameter.

Please forward the results so that we can check if your vCenter returns any virtual machines via the API.

Best regards, Felix

Created on Feb 27, 2018 1:22:30 PM by  Felix Saure [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hey Baba,

We received the logs, but I wont publish them to not leak any of your private information.

One thing, which obviously will not work is this one:

NetVersion: v4.0.30319

Update the .net version to the most recent version and see if the sensors work.

Best regards, Felix

Created on Feb 28, 2018 9:12:57 PM by  Felix Saure [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hey Felix

Strange - the installed version is .NET 4.7 (updated myself), and the Server is a fresh installation of 2012R2 where the build in version is 4.5 out of the box.

But you are right, the core install path is always .NET 4.0 predefined by Microsoft (see in registry). https://ibb.co/dK9eyH

What now ? :-)

best regards, Baba

Created on Mar 1, 2018 10:23:43 AM by  BABA (0) 1



Votes:

0

Your Vote:

Up

Down

Hi Felix

I think something was wrong with my last post - sorry for the delay.

as you recomended i checked the .net version on my probe system and it is 4.7, but shows in log file as 4.0.30319 and this is the correct default install path. in the registry it shows the right version 4.7.02053 and release (460805).

next i ran the cli command with the parameter "host" and "vm", and in both cases it shows me the hosts and vm's in the cli and in the log file. everything seems to work but i still can't add the vmware SOAP sensor. the error message is "Sorry, the scan for available monitoring items has failed!"

thx in advance for your help

best regards, baba

Created on Mar 16, 2018 8:22:17 AM by  BABA (0) 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.