What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

Historic Data Graph blank

Votes:

0

Your Vote:

Up

Down

Hi all,

I'm running PRTG version 18.1.38.11934+ and the Historic Data is not showing, it's just a blank square. Data is there, the table with the data is populated ok; the issue is only with the Graph.

Is anyone experiencing the same issue? I tried Chrome, Firefox and IExplorer with the same problem.

Regards!

historic-data prtg sensor

Created on Mar 22, 2018 8:30:05 AM by  otakuinside (0) 1



7 Replies

Votes:

0

Your Vote:

Up

Down

This is how I see the report: https://i.imgur.com/sDgdN1I.png

Created on Mar 22, 2018 9:08:54 AM by  otakuinside (0) 1



Votes:

0

Your Vote:

Up

Down

Hi there,

Please check that you have entered the correct DNS-Name of the Core Server under "Setup > System Administration > User Interface". The Graph-Urls are generated with the entered value there.

Best regards.

Created on Mar 22, 2018 9:41:13 AM by  Dariusz Gorka [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi,

yes, it's ok. It was working until some past update (I can't say which since I'm not using that feature a lot). What I mean is that there has been no configuration changes on the prtg server, so I guess it's something on the version, a new bug.

Regards..

Created on Mar 23, 2018 12:36:27 PM by  otakuinside (0) 1



Votes:

0

Your Vote:

Up

Down

Hi there,

Such a bug would already be known or alerted by other customers, which is unfortunately, not the case. Please right click on the not displaying picture and open in another tab, what URL do you get?

Additionally, please try to connect locally on the Core Server itself, generate a report and check if the graphs are displayed there.

Best regards.

Created on Mar 23, 2018 1:10:57 PM by  Dariusz Gorka [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Actually, I have the very same issue here (no idea when this started; I only just got alerted today about this).

It looks like it has something to do with user rights, since some users do see the graph (including myself, but I'm an administrator within PRTG) but others don't see the graph.
They do see all values though.

Was this ever solved?

Created on Feb 21, 2019 2:10:02 PM by  Corné van den Bosch (61) 1 1



Votes:

0

Your Vote:

Up

Down

Hi there,

As you can see in the answers before, the affected user haven't replied yet. Have you tried restarting the Core Server?

Best regards.

Created on Feb 21, 2019 7:24:10 PM by  Dariusz Gorka [Paessler Support]



Votes:

1

Your Vote:

Up

Down

Found the issue:

The user was using the external URL for accessing PRTG, going through the LoadBalancer.
But because of how the URL is constructed, the LoadBalancer blocked the URL because of suspected for SQL Injection.

I've arranged for this to be changed for this URL, and now it's working...

Created on Feb 22, 2019 1:45:16 PM by  Corné van den Bosch (61) 1 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.