New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


SNMP suddenly not working anymore

Votes:

0

Your Vote:

Up

Down

Hey,

we used builtin "SNMP APC Hardware / SNMP library apc-related" sensor to monitor 4 APC UPS devices for literally years without errors/warnings.

Since 2018/03/07 all of the sensors would show SNMP error 2003 and I can't seem to figure out why.

We use a custom SNMP Community for the requests and everything works just finde outside of PRTG console. I can SNMP request via Powershell and also via Paessler SNMP Tester from my local machine as well as PRTG host.

Strangely when I restart the mgmt interface of the UPS I get some results from PRTG but these last for maybe only 5-10 request (interval = 5 min). Requests "outside" of the sensor work just fine (SNMP Tester or Powershell).

I already tried the following: - reboot of PRTG / reboot of UPS - increased interval time - recreated device in PRTG - recreated SNMP community / tried different communities - recreated the sensors (APC sensor, SNMP library, and custom SNMP sensor)

Are there any known issues with the March 7th 2018 – Version 18.1.38.11934 or March 19th 2018 – Version 18.1.38.11958 Update?

(Another thing I would like to mention is, that although I set the interval to e.g. 5 minutes, the first requests don't take care about the interval )

Thanks in advance!
lukas_sch

apc prtg snmp snmp-error#2003 ups

Created on Mar 28, 2018 10:57:02 AM by  Lukas (320) 2 1



3 Replies

Votes:

0

Your Vote:

Up

Down

Hello,

Have you tried re-creating the sensors? There are no issues with those updates.

Do you know if the UPS is using SNMPv1 or SNMPv2c?

Created on Mar 30, 2018 6:17:34 AM by  Benjamin Day [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hey Benjamin,

as I said, I recreated the sensors. I tried these two: {{https://i.imgur.com/VTzxarg.png|} and SNMPCustomSensor using all kinds of APC OIDs.

Requests work fine for like 5-10 requests but then stop working. We are using SNMPv1.

Created on Apr 3, 2018 6:04:41 AM by  Lukas (320) 2 1



Votes:

0

Your Vote:

Up

Down

Can you check and see if there is a firmware update for your APC unit?

You still run these at 5 minute intervals. Can you try doing 1 hour intervals for the time being?

I'd like to see if it is a quantity issue of the amount of polls, or if it's a timing issue.

Created on Apr 3, 2018 10:53:27 PM by  Benjamin Day [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.