New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


EXE/XML Sensor : Limitmode is ignored

Votes:

0

Your Vote:

Up

Down

Hi support,

I have this code (showed below just the first chanel of the sensor) :

Write-Host "<prtg>"

            Write-Host "<result>"

            Write-Host "<channel>Age labase.sql (local)</channel>"

            Write-Host "<value>"([math]::Round(((get-date)-$valeur_labase_sql.LastWriteTime).Totalminutes))"</value>"

            Write-Host "<LimitMaxError>1440</LimitMaxError>"

            Write-Host "<LimitMode>1</LimitMode>"

            Write-Host "</result>"

           [...]

Write-Host "</prtg>"

Exit 0

And powershell return this:

<prtg>

<result>

<channel>Age labase.sql (local)</channel>

<value> 3562 </value>

<LimitMaxError>1440</LimitMaxError>

<LimitMode>1</LimitMode>

</result>

[...]

<prtg>

However, my sensor never goes down.

What should I do ?

Cordially.

exexml limitmode powershell

Created on Apr 26, 2018 9:43:49 AM by  John Doe (0) 1

Last change on Apr 27, 2018 7:05:06 AM by  Birk Guttmann [Paessler Support]



3 Replies

Votes:

0

Your Vote:

Up

Down

Hello there,

Thanks for your inquiry, we appreciate your contact regarding this matter!

The limits set in a script are only used when creating the Sensor, after the sensor has been created, these are no longer taken into account. You can change the limits in the channel settings (click on the corresponding channel in the sensor overview).

Please let me know if this explains the behavior.


Kind regards,
Birk Guttmann, Tech Support Team

Created on Apr 27, 2018 7:09:12 AM by  Birk Guttmann [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello,

I understand. But on fresh installation, the sensor does not use the limit.

I think that will not do the job: my script will use different limit depending the day of the week. By exemple : if the day is monday, the limit is 1440 if the day if saturday, the limit is 4320

Is this possible ?

Created on May 11, 2018 10:12:46 AM by  John Doe (0) 1



Votes:

0

Your Vote:

Up

Down

Hello John,

By default this is not possible. As workaround you can do the following:
- Create one Sensor with the limit for Monday and one with the limit for Saturday.
- Create a schedule (Setup | Account Settings | Schedules) for only Monday and one for only Saturday.
- Assign this schedules in the corresponding Sensor settings

This way the Sensors with the corresponding limits will only run in the specified time spans.


Kind regards,
Birk Guttmann, Tech Support Team

Created on May 11, 2018 10:36:07 AM by  Birk Guttmann [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.