New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


At my wits end regarding DNS lookups/failures

Votes:

0

Your Vote:

Up

Down

I have a small install of PRTG I have been running in a lab environment for evaluation for potential purchase for a much larger network. I have approximately 20 or so sensors.

In a workgroup, using Linux DNS server. DNS is working, has worked, and works well on the network.

Started to get Ping alerts basically due to DNS Lookup failures and I have no idea why. It isn't all the time, but sometimes. I finally decided to look into it more today. For those sensors I am currently getting active DNS lookup failures (Error 11004), I can execute an nslookup without issue directly from the command line on the server PRTG.

As I was troubleshooting, the ONLY thing I changed was the local probe IP from auto to the actual static IP address. Within about 5 minutes, I got SNMP errors on all of my switchports that have been working just fine up until now.

Getting no response errors. So I changed IP Address for probe back to auto, no change.

Downloaded the SNMP tester and here is the interesting thing - I am able to walk the switch when I use the IP Address, but it says hostname lookup failed when I try to walk by hostname. I am running this from the PRTG server and when it fails lookup, I can again open CMD and complete a successful nslookup.

Does anyone know why this is happening?

Edit: Update - I realized on the tester, I was only trying to connect using hostname - when I added the suffix (not on a domain, on a workgroup, but with the suffix wrkgrp.miller) it walked just fine.

So, what am I missing here, why is SNMP not working then? I have checked the community string, firewall isn't an issue - pretty basic setup.

dns-resolution error snmp

Created on May 30, 2018 12:43:36 AM by  shelzmike (0) 1



2 Replies

Votes:

0

Your Vote:

Up

Down

Hi there,

PRTG uses the DNS cashes of Windows, so does the SNMP Tester. It's indeed unexpected that it works after adding the suffixes. I'd recommend to start a Wireshark capture on the PRTG host with a filter for UDP packets on port 161. In case of an error it would be interesting to which target IP address the packets are sent and if there are any responds packets arriving.

Best regards, Felix

Created on May 30, 2018 12:11:24 PM by  Felix Saure [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Yeah, it is very strange. I was able to figure out that if I changed the community string back to public (which I hate to do), everything starts working suddenly. I'm not sure why the problem suddenly happened though as I had been using a custom community string for 6 months without any issue. Also, the custom St worked just fine in the tester so long as I added the suffix.

Created on May 30, 2018 10:59:48 PM by  shelzmike (0) 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.