New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Unable to start PRTG Core Server Service after upgrade

Votes:

0

Your Vote:

Up

Down

Hi Team,

I've done a bit of google'ing on this one without much luck. I was running a free PRTG instance on a Windows 2012R2 server. I had version 18.1.36.3728 installed and decided to upgrade to 18.2.41.1652.

I opened the PRTG Enterprise Console, went to the Setup tab for my local server > PRTG Status > Auto-Update and clicked the update button. My console shut down and I assume the update process began. I waited for a few minutes and noticed that I didn't get an email saying the service successfully updated like it usually does.

I opened the Enterprise console and was presented with the Devices tab and my local server had the status: ---------------------------- "Not Connected (Error in content: ). ----------------------------

I checked the PRTG EC Log (C:\ProgramData\Paessler\PRTG Network Monitor\Logs (System)\PRTG EC Log (1)) and saw the following three lines repeating: ---------------------------- 28/06/2018 3:38:51 PM Get status 6(Exception): http://127.0.0.1:80/api/table.xml: Not Connected (Error in content: ) 28/06/2018 3:38:55 PM Get status 2(Exception): https://127.0.0.1:443/api/table.xml: Socket Error # 10061 28/06/2018 3:39:01 PM Get status 6(Exception): https://127.0.0.1:443/api/table.xml: Not Connected (Error in content: ) ----------------------------

I then opened the PRTG Administration Tool and checked my Web Server settings and Administrator credentials where correct. I saved & closed the tool and reopended the Enterprise Console but was still getting the "Not Connected" status message. I went back to the Admin Tool, clicked on the Service Start/Stop tab and clicked "Start Core Server (ignoring changed settings).

After a small delay, the follow messages where displayed: {{{---------------------------- 1st Msg PRTG Core Service Service could not be started. The service did not respond to the start or control request in a timely fashion.

2nd Msg Sorry, could not start the PRTG Core Server (Web Server) Please check the PRTG Core Server Log. ----------------------------}}}

I then went to look at the PRTG Core Server Log (C:\ProgramData\Paessler\PRTG Network Monitor\Logs (System)\PRTG Core Server Log (1)), but it was showing as not updated in over an hour and last log message was simply: ---------------------------- 28/06/2018 1:42:45 PM System Cleanup Done ----------------------------

Next thing to check was the PTRG Core Server Service via services.msc. It was set to "Automatic" but not running. When I went to manually start the service I got the follow message after a small delay: ---------------------------- Windows could not start the PRTG Core Server Service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion. ----------------------------

At this point I decided to perform a soft reboot on the server just in case the update process was hung on something. After reboot, still getting the same result as above.

I then restored the PRTG Configuration.old file to its original .dat extension (and renamed the existing .dat file). Still not able to star the PRTG Core Server Service. I also tried restoring the dat file from the previous day using the Configuration Auto-Backups folder, but no luck.

Lastly, I looked in the Windows Event Log, the Application log presented a single error that I could get much more info on. It appears about 45 minutes after the update is applied, may or may not be related: ---------------------------- Faulting application name: PRTG Probe.exe, version: 18.1.36.3728, time stamp: 0x5a4f6fd5 Faulting module name: PaesslerSNMPWrapper.dll, version: 6.3.9600.18895, time stamp: 0x5a4b127e Exception code: 0xc0000135 Fault offset: 0x0009d4e2 Faulting process id: 0xaec Faulting application start time: 0x01d40ea73961cd3b Faulting application path: C:\Program Files (x86)\PRTG Network Monitor\PRTG Probe.exe Faulting module path: PaesslerSNMPWrapper.dll Report Id: 773e07a2-7a9a-11e8-80fa-005056be2577 Faulting package full name: Faulting package-relative application ID: ----------------------------

The System log was showing the following error several times, for the manual service starts failing, I presume: ---------------------------- A timeout was reached (30000 milliseconds) while waiting for the PRTG Core Server Service service to connect. ----------------------------

Sorry, there's a ton of info there, but if anyone feels keen to have a crack I would be very appreciative! Hopefully my formatting doesn't get too mangled by the editor... :P

Kind Regards Jack

core-service prtg sadface update

Created on Jun 28, 2018 8:04:14 AM by  Heavyghost (0) 1

Last change on Jun 28, 2018 9:48:36 AM by  Erhard Mikulik [Paessler Support]



4 Replies

Votes:

0

Your Vote:

Up

Down

Hi Jack,

Please download the latest version from here and run it manually, this should fix it.

Kind regards,

Erhard

Created on Jun 28, 2018 9:18:06 AM by  Erhard Mikulik [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi Erhard,

Thanks for your quick reply. Sorry for the delay in getting back to you. I've been out of the office for a few days. I have grabbed the setup file you linked and re-run through the install process and that has done the trick, thank you very much!

Kind Regards, Jack

Created on Jul 4, 2018 6:15:09 AM by  Heavyghost (0) 1



Votes:

0

Your Vote:

Up

Down

Great, good to hear that fixed it, you're welcome.

Created on Jul 4, 2018 6:29:08 AM by  Erhard Mikulik [Paessler Support]



Votes:

0

Your Vote:

Up

Down

i had the exact same problem and downloading the file and manually running the upgrade worked for me.

Created on Aug 27, 2018 2:25:28 PM by  cavery (0)



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.