New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Why do I get DoS Alarms on my QNAP?

Votes:

0

Your Vote:

Up

Down

I updated my QNAP recently and am now receiving DoS alarms when monitoring it via SNMP. What is causing this and what can I do about it?

ddos prtg qnap system-information

Created on Jul 13, 2018 7:33:30 AM by  Brandy Mauff [Paessler Support]

Last change on Jul 17, 2018 7:08:05 AM by  Brandy Mauff [Paessler Support]



1 Reply

Accepted Answer

Votes:

1

Your Vote:

Up

Down

This article applies to PRTG Network Monitor 19 or later

QNAP SNMP DoS Alarms and System Information

With certain QNAP firmware versions, you might receive the alarm [SNMP] DoS detected for PRTG when using the System Information feature. This is not an error in PRTG but instead is caused by a setting on the QNAP itself.

The System Information feature scans your PRTG installation once every 24 hours to show all available system information data for your devices.

The QNAP has a built-in DoS checking feature that defaults to 300 SNMP packets per second. This limit can be easily reached when using the System Information feature.


SNMP monitoring with QNAP and custom sensors might also trigger this alarm. This might be because of issues with certain QNAP firmware versions, for example 4.3.3 or 4.3.4. See the QNAP forum for more information.


Solution 1: Disable DoS Detection

Important: Make sure that this solution is in line with your company's security policy before you disable DoS detection.

If you do not want to receive the [SNMP] DoS detected alarms, you can disable the DoS detection in the QNAP's settings. Simply run the following command.

# setcfg SNMP EnableDetectDDoS FALSE

Then you need to restart SNMP.

# /etc/init.d/snmp restart


Alternatively, you can also increase the maximum number of requests using the following command.

# setcfg SNMP MaxPacketPerSecond XXX


Solution 2: Disable System Information

If you do not want to disable DoS detection, you can disable the System Information feature in the PRTG web interface.

  1. In the device's settings, go to the Advanced Network Analysis section.
  2. Under System Information, select Disabled.

The System Information feature is now disabled for the device.

Solution 3: Disable Disk Hibernation

To disable disk hibernation, proceed as follows: Go to Control Panel | System Settings | Hardware | HDD Standby, and disable it. Afterwards, the sensors should work without further issues.

Created on Jul 13, 2018 7:44:54 AM by  Brandy Mauff [Paessler Support]

Last change on May 21, 2019 11:28:54 AM by  Maike Behnsen [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.