New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


How to disable HTTP 302 response or disable Host header check in PRTG web server

Votes:

0

Your Vote:

Up

Down

I have installed PRTG and I want to access the web inteface on a non-standard port. Currently the PRTG server is deployed behind a firewall performing NAT/PAT.

The PRTG server has an IP address, IP1, and is running the web server on port 443. I connect to an IP configured on the firewall, IP2, on a custom port, Port2. The request is successfully translated by the firewall, and PRTG receives the connection on port 443 but the PRTG server sees the port number in the Host header of the HTTP request and responds with an HTTP 302 response, advising to change the port.

So a request sent to IP2, Port2, receives an HTTP 302 response advising to connect to IP2, port 443, which is the firewalls admin interface. IP2 isn't even configured in PRTG, so it's unclear why it doesn't also try to change this, but that's not important.

So, I need to know how to disable HTTP 302 responses, configure PRTGs web server to ignore incorrect Host headers or any other work around available to resolve this issue.

Thanks in advance.

302 temporarily-moved web-server

Created on Aug 20, 2018 2:05:13 PM by  SideKick321 (0) 1



4 Replies

Votes:

0

Your Vote:

Up

Down

So, I implemented the obvious workaround of changing the port the PRTG web server is running on, and using a simple open port on the firewall instead of PAT, and this works but I would still be interested to hear any feedback on my original question regarding the handling of the Host header as there are situations where this kind of configuration may be desired.

Thanks, SideKick321

Created on Aug 21, 2018 9:50:34 AM by  SideKick321 (0) 1



Votes:

0

Your Vote:

Up

Down

Hi SideKick321,

Thanks for your inquiry and thanks for letting us know about your workaround.

The best solution would be to use a Reverse Proxy here. That way it is possible to remove, add and/or modify response headers, so they are no longer "incorrect".

Please let me know if that fits your requirements. For any further questions or issues, we're glad to help.


Kind regards,
Birk Guttmann, Tech Support Team

Created on Aug 21, 2018 1:55:17 PM by  Birk Guttmann [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi Birk,

Unfortunately we do not have and will not be getting a reverse proxy any time soon, so we're stuck with the UTM for handling the connection.

I'm guessing there's no way to edit the PRTG web servers settings at this level of detail.

Luke

Created on Aug 24, 2018 7:43:04 AM by  SideKick321 (0) 1



Votes:

0

Your Vote:

Up

Down

Hi Luke,

Unfortunately it is not possible to set up the PRTG Web Server that way.


Kind regards,
Birk Guttmann, Tech Support Team

Created on Aug 24, 2018 12:34:03 PM by  Birk Guttmann [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.