New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


SNMP Trap Receiver Syntax

Votes:

0

Your Vote:

Up

Down

This is the SNMP Trap message received via PRTG within the messages tab of the SNMP Trap Receiver Sensor from a Cisco IOS Device.

SNMPv2-MIB::snmpTrapOID.0 = SNMPv2-MIB::authenticationFailure
CISCO-SMI::local.1.5.0 = x.x.x.x
CISCO-SMI::ciscoMgmt.412.1.1.1.0 = 1
CISCO-SMI::ciscoMgmt.412.1.1.2.0 = x.x.x.x

x.x.x.x is an IP Address

Also the TrapGen within the message = 4

No matter how I configure the Warning Filter using bindings I can not get this to alarm

bindings [authenticaitonFailure]
bindings[authenticationFailure]
bindings["authenticationFailure"]
bindings ["authenticationFailure"]
bindings [SNMPv2-MIB::snmpTrapOID.0 = SNMPv2-MIB::authenticationFailure]

etc etc etc

However if I use

trapgen[4]

Perfect....

However, I want to be able to trigger on Text within the bindings

What is wrong with the above syntax?

alarm snmp snmptraps

Created on Sep 19, 2018 3:14:06 PM by  taylorf5 (10) 1

Last change on Sep 21, 2018 4:12:41 AM by  Sebastian Kniege [Paessler Support]



2 Replies

Votes:

0

Your Vote:

Up

Down

Each of the binding statement were on there own separate line when I posted this...

bindings [authenticaitonFailure] 
bindings[authenticationFailure] 
bindings["authenticationFailure"] 
bindings ["authenticationFailure"] 
bindings [SNMPv2-MIB::snmpTrapOID.0 = SNMPv2-MIB::authenticationFailure]

etc etc etc

What is wrong with the above syntax for PRTG to pick up the word autheticationFailure and create a warning alarm as a result.

Created on Sep 20, 2018 2:27:42 PM by  taylorf5 (10) 1

Last change on Sep 21, 2018 4:13:09 AM by  Sebastian Kniege [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello tyalorf5,

Thank you very much for your knowledge base post.

I am not quite sure yet if the behavior is caused by a possible bug, therefore I need to see your current configuration in detail. For this, I need you to create a full-screen screenshot from the sensors Messages and Settings tab. Please don't crop and resize the screenshots.Afterwards upload them somewhere and attach them to your next reply as described here (scroll down to Images).

Best regards,
Sebastian

Created on Sep 21, 2018 4:22:08 AM by  Sebastian Kniege [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.