New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Monitoring different VLANS

Votes:

0

Your Vote:

Up

Down

Hi,

I have a network that has a VLAN in it, and I would like to monitor that VLAN with my PRTG. The servers don't have any firewalls running on them, and all the ports are opened on the LAN Segment.

I can ping them, however, the WMI traffic does not go through. Does anyone know why that is? The WMI tester just gives me a regular error that says: RPC port 135 not accessible. Has anyone ever experienced this problem and found a solution for this? Or have I done something wrong?

Regards.

sensor vlan wmi

Created on Oct 31, 2018 8:20:47 AM by  svenvandorst (50) 2 1



5 Replies

Votes:

0

Your Vote:

Up

Down

You likely have a generic WMI issue - might be a credentials issue or something else...

A good start is always to use commands like

WINMGMT /VERIFYREPOSITORY

On the target system to see if it finds issues...

There is a lot of information here as well: https://kb.paessler.com/en/topic/1043-my-wmi-sensors-don-t-work-what-can-i-do

Regards

Florian Rossmark

www.it-admins.com

Created on Nov 1, 2018 10:00:48 PM by  Florian Rossmark (4,251) 4 2



Votes:

0

Your Vote:

Up

Down

Hi Florian,

Thanks for your reply once again.

I've tried quite a lot, however, it's not a credentials problem. I have tried multiple things, and have not gotten a good result yet. I neither can't log in on the servers because I do not have the permissions for that.

The credentials to the active directory, however, are 100% correct. There's 1 AD in the whole network, and the service accounts work on all the other machines.

Could it be the problem that I have to install a remote probe on the VLAN instead of just adding regular sensors?

Regards,

Created on Nov 2, 2018 8:29:17 AM by  svenvandorst (50) 2 1



Votes:

0

Your Vote:

Up

Down

I have gotten the permissions to access the servers that are currently experiencing the problem. I tried the command you gave me, and got the error ''0x80041003 Acces Denied''.

Regards,

Created on Nov 2, 2018 10:44:14 AM by  svenvandorst (50) 2 1



Votes:

0

Your Vote:

Up

Down

Hi Sven,

The access denied message is related to insufficient access rights to access this information via WMI. If you try to use a domain administrator account, does the scan work properly?

Best regards, Felix

Created on Nov 2, 2018 12:09:38 PM by  Felix Saure [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi Felix,

Thanks for your reply. The service account is a domain administrator. I think the problem is that the LAN ports are all opened, but the VLANs can't communicate with the WMI port through each other.

I'll keep this post updated!

Thanks.

Created on Nov 2, 2018 12:12:13 PM by  svenvandorst (50) 2 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.