New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


syslog receiver not opening port?

Votes:

0

Your Vote:

Up

Down

Hey,

I am trying to set up a syslog-ng server on Linux (not in domain) and send the logs to a domain joined PRTG server on a device probe. (It's just default settings at the moment).

The problem is that I keep getting connection refused (111) from the syslog-ng server and when I run nmap on the prtg destination, I don't see port 514 as open, even though it should be running.

However when I run netstat -anob on the Windows machine with the Device probe I can see something is using the port, even when I tested with another port, that also came up.

I have checked Microsoft Firewall and Firewalld on Linux, but there should be nothing blocking the ports.

So I am kind of stumped as to what to do next, I tried watching the video they provided but there it just works without a hitch.

Is it because that the machine NEEDS to be in the domain, before prtg even wants something to do with it or am I missing something?

connection-refused linux syslog-sensor

Created on Feb 7, 2019 12:50:15 PM by  hanz301 (0) 1



4 Replies

Votes:

0

Your Vote:

Up

Down

Is there no one that has had this setup before? TCPView also says that it is there running on the probe, but it's not listening

Created on Feb 7, 2019 2:13:20 PM by  hanz301 (0) 1



Votes:

0

Your Vote:

Up

Down

Dear hanz301,

Thank you very much for your contact and please apologize the long delay on this.

Please allow me to review your current setup and result of the sensor. For this, please upload a full-screen screenshot that covers the Overview and Settings tab of the Syslog sensor.

Please re-view the syslog-ng configuration once more and make sure that the connection to PRTG is UDP not TCP. Last but not least allow me to ask what PRTG version you are currently running?

Thank you very much in advance.
Sebastian

Created on Feb 11, 2019 5:38:13 AM by  Sebastian Kniege [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello, thanks for coming back to me.

I fixed it with much frustration, the fix was indeed UDP. But I also had to put the receiver on a local probe, before it actually wanted to pick up the messages.

Created on Feb 11, 2019 7:16:54 PM by  hanz301 (0) 1



Votes:

0

Your Vote:

Up

Down

Hello hanz301,

Thank you very much for your feedback. I'm glad to read that you was able to find a solution.

Best regards,
Sebastian

Created on Feb 12, 2019 6:47:46 AM by  Sebastian Kniege [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.