What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

PRTG Data Extractor Command line



Hi guys, I am playing with the Data Extractor from Paessler. I know it is not supported anymore but maybe you can still answer a simple question where I am really struggling at moment. I tried the app itself and when I added username and password it is working as I hoped. So I wanted to run the tool via task scheduler so I tried following from the cmd

Dataextractor.exe -prtghost "localhost" -prtguser "prtg-user" -prtgpw "<yourprtgpassword>" -dbserver "SQL SERver" -db "PRTG_Extractor" -dbuser "PRTG-Extractor" -dbpw "<yourdbpassword>"

but this did not work. I simply get the blinking cursor and nothing happen.

Does someone know what I am doing wrong?

data-extractor dataextractor sql

Created on May 8, 2019 11:09:26 AM

7 Replies



Does it work when you execute the line manually in the command line?

Created on May 8, 2019 3:46:30 PM by  Stephan Linke [Paessler Support]



Sorry for my late reply. I did some additional testings in the meanwhile. If the access is possible via Port 80 I am adding the parameter -prtgport "80" and it is working.

If the access to PRTG is only possible via https I tried to change the parameter to Port 443. but this did not help.

How is the flag https in the extractor enabled on command line?

Created on Jun 6, 2019 6:01:38 AM



It might be possible that only TLS 1.0 is supported for this, not quite sure. What protocols are allowed within your webserver? They can be checked via

SetupSystem AdministrationUser InterfaceWeb ServerConnection Security

Created on Jun 6, 2019 6:44:34 AM by  Stephan Linke [Paessler Support]



Well this is not the reason why it is not working. When I manually set the flag https enabled on the Data Extractor it is working. I simply need to understand which parameter I need set to mark the flag https

Created on Jun 6, 2019 7:05:28 AM



Ah, now I get it. Sorry, this was a misunderstanding on my end. The parameters accepted in the commandline are the following:

  • -prtghost
  • -prtguser
  • -prtgpw
  • -prtgport
  • -dbserver
  • -db
  • -dbuser
  • -dbpw
  • -sensorserver
  • -sensorport
  • -sensortoken
  • -idfrom
  • -idto
  • -dbsspi
  • -nosensordata
  • -notoplistdata

Unfortunately, HTTPS isn't one of them. Since the PRTG webinterface does redirect any incoming connections to HTTPS automatically, this shouldn't be an issue. However, I'm not sure, why it's not working on your end :/ I'm afraid that we won't come to a satisfying conclusion here, as the tool is practically abandonware...

Created on Jun 6, 2019 7:32:27 AM by  Stephan Linke [Paessler Support]



Thanks a lot for your reply (and sorry for my late answer).

At the end I created a workaround and was able to get the connection through port 80.

Just one more question: When the Database instance is running on a different port like 9877 and not 1433 is there a way to add the Port of the DB instance?

Created on Jun 26, 2019 8:46:37 AM



Hi there,

As far as I can tell there is no dedicated parameter for db port, the ui of the extractor also has no field for it. Does it fail when running on port 9877 for example? You could try appending the port like "yourdbserver:9877".

Kind regards,


Created on Jun 26, 2019 11:04:44 AM by  Erhard Mikulik [Paessler Support]

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.