What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

How can I get SNMP v3 to work on my sensors



So I have two similar devices Dell iDRACs we had both devices responding correctly but we wanted to start to use one general SNMP user. I changed the snmp creds on device 1 to SNMP V3 and all sensors came up green. I then went to the second device that is setup exactly the same but when I input the creds the sensors go read and give me a SNMP Error 2011. I have tried to add the SNMP Uptime sensor and get the same error. When I switch to SNMP V2 everything comes up but we can not leave it like that due to security reasons. Any help is appreciated.

sensors snmp snmpv3

Created on Jan 24, 2020 6:54:26 PM

3 Replies



Hi there,

Are you able to confirm that SNMP v3 is also properly set-up on the iDRAC device? If this is the case, it's necessary to adjust the SNMP configuration in PRTG on device level (Credentials for SNMP Devices) as well. It's difficult to predict what the actual causer of this behavior, but using our SNMP Tester might be worth using for your analysis. Please make sure to execute the Tester on the same Probe as the affected sensor.


Created on Jan 27, 2020 12:44:03 PM by  Sebastian Kniege [Paessler Support]



A restart of the Probe service fixed the issue

Created on Jan 30, 2020 6:16:24 PM



Great to hear that :)

Created on Jan 31, 2020 5:37:55 AM by  Sebastian Kniege [Paessler Support]

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.