What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

PRTG Notifications returning SSL Error

Votes:

0

Your Vote:

Up

Down

I have a notification set up in PRTG that is performing an http action to send notifications via slack webhook. Currently every time a sensor is put in an alarm state, the notification throws the following error:

Failed to establish secure connection [Step 0] Error connecting with SSL. Error connecting with SSL. error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol.

I've confirmed that the probe settings for monitoring requests are set to "auto" in the probe settings for monitoring in the prtg admin console. This issue started occurring out of nowhere last month and the webhooks currently are not working with slack.

Server Service: V18.2.41.1652 Probe Service: V18.2.41.1652

error prtg ssl

Created on Apr 13, 2020 1:42:19 PM by  araotle (0) 1



12 Replies

Votes:

0

Your Vote:

Up

Down

Hi there,

Did you changed anything like certificate your used TLS version in your network?

Created on Apr 14, 2020 6:52:17 AM by  Moritz Heller [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi,

Not recently no.

Created on Apr 14, 2020 1:24:03 PM by  araotle (0) 1



Votes:

0

Your Vote:

Up

Down

The error message indicates that the target device or a firewall in between rejects the connections. Did you already tested the webhook without PRTG (e.g. Powershell command "invoke-webrequest")?

Created on Apr 15, 2020 7:07:02 AM by  Moritz Heller [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Yes I don't have an issue there. There is no firewall preventing these connections. They are also working intermittently. My alerts worked all day yesterday but today the same alerts are returning the above error message on the same sensors in the same conditions. No network changes have been made from yesterday to today.

Created on Apr 22, 2020 5:48:55 PM by  araotle (0) 1



Votes:

0

Your Vote:

Up

Down

In this case, please enable the notification delivery logging and check the corresponding log file.

Created on Apr 23, 2020 7:02:43 AM by  Moritz Heller [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I'll get this set up and follow up.

Created on Apr 24, 2020 1:38:28 PM by  araotle (0) 1



Votes:

0

Your Vote:

Up

Down

Which logs am I looking for specifically? I have Debug, Sensor, System and Web Server logs. The Debug logs contain the following messages:

error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol [Step 3] Error connecting with SSL. Error connecting with SSL. error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number [Step 4] Error connecting with SSL. Error connecting with SSL. error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number [Step 5] Error connecting with SSL. Error connecting with SSL. error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol [Unsecure] IOHandler value is not valid

Created on Apr 28, 2020 8:42:31 PM by  araotle (0) 1



Votes:

0

Your Vote:

Up

Down

Hi,

You'll find the needed logs in the following folder path on your core server system C:\ProgramData\Paessler\PRTG Network Monitor\Logs\debug.

Created on Apr 29, 2020 11:32:10 AM by  Marijan Horsky [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Those logs contain the message listed above. Could this be related to Slack deprecating TLS 1.0 and 1.1?

https://api.slack.com/changelog/2019-07-deprecate-early-tls-versions

Created on Apr 29, 2020 4:07:34 PM by  araotle (0) 1



Votes:

0

Your Vote:

Up

Down

Hi,

Could you please let me know if it is deprecated or will it be deprecated in the next times?

Created on Apr 30, 2020 12:02:58 PM by  Marijan Horsky [Paessler Support]



Votes:

0

Your Vote:

Up

Down

According to the article it is. However these notifications have been working for about a week with no issue. The problem started again yesterday. How can I find the ticket # of this case so I can submit the appropriate logs?

Thanks.

Created on May 15, 2020 2:09:41 PM by  araotle (0) 1



Votes:

0

Your Vote:

Up

Down

Hi,

Please us the following Ticket Number to provide us a support bundle: PAE2005761.


Kind regards Marijan

Created on May 15, 2020 6:43:31 PM by  Marijan Horsky [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.