What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

Web server port keeps changing.

Votes:

0

Your Vote:

Up

Down

First off, I have the free version, so if I don't rate a response, just let me know.

I've searched the knowledge base, and can't seem to find a relevant topic. If there's one out there, feel free to pp9oint me at it.

The web server port keeps changing form 443 (normal https) to 8443 and back. It's just a nuisance, at this point, and not something I'd even consider paying for.

Is there a way to stop this behavior from happening? I can't seem to specify the port, but the web server randomly changes it. I'm using it (right now) in a home environment, and keep it updated through the web interface, as often as updates are available.

This change will happen after an update, when the core/probe restarts, or after a host server reboot.

Other than this issue, I really like the product. There's no way I can recommend this for a production environment, though, with this issue. Creating public "view" maps is awesome, and being able to provide something simple like that for management to view (I don't want them messing with anything, just want them to be able to view) can be really helpful. They can view the status of the network before they call IT and complain about something.

Thanks for whatever information can be provided.

prtg-core web-server

Created on Jul 18, 2020 10:20:44 PM by  chaissos (0) 1



6 Replies

Votes:

0

Your Vote:

Up

Down

Hi there,

Thank you for your post.

If the webserver changes its port from 443 to 8443, port 443 is already taken by another application. Therefore, if this heppends again, I recommend to use the cmd command "netstat -ano | find "443"" to check which process id uses this port.
To identify the process, please use the "tasklist | find "*PID"".

In addition, you can also define a custom port for your WebServer. Therefore, you need to open the PRTG Administration Tool on the server where the Core Server runs. Afterwards, select the "PRTG Web Server" tab and set the option "Select TCP Port for the Web Server" to "Expert configuration".

Created on Jul 20, 2020 9:40:46 AM by  Moritz Heller [Paessler Support]

Last change on Jul 20, 2020 9:41:20 AM by  Moritz Heller [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Thanks for the feedback.

I did initially set the port to 8443 using the admin tool, and it worked fine for a while, then mysteriously jumped to 443.

Month or so later, back to 8443. And it's done that ever since. I want to say I've been using it 6-8 months now, and I do like the product.

So I reset it - again - and I guess I'll wait and see what happens. It's running on the host machine, with 3 other servers on top of it. On this box, none of them has a regular web server running. Both my web servers (regular www, and Exchange) are on another box, running in VMs.

Created on Jul 22, 2020 11:48:14 AM by  chaissos (0) 1



Votes:

0

Your Vote:

Up

Down

Thank you for the feedback. Please let me know whether the issue occurred after you configured the custom port again.

Created on Jul 22, 2020 1:34:30 PM by  Moritz Heller [Paessler Support]



Votes:

0

Your Vote:

Up

Down

It seems the latest update changed the server port again. So maybe it was updates all along that did it, and I didn't notice the correlation.

Created on Aug 23, 2020 11:46:02 AM by  chaissos (0) 1



Votes:

0

Your Vote:

Up

Down

Please let me know whether the issue still persists after you changed the port again? In addition, do you use the custom port feature in the PRTG Administration Tool?

Created on Aug 24, 2020 5:58:17 AM by  Moritz Heller [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Right. Updated the server port to 443 via the administration tool on the server itself, services restarted. Updated the port in the web interface from a client, logged in as admin.

Now to watch and wait. It should stay right there for now.

The big test will be to see if it changes after the next update. No idea when that will be, though.

Created on Aug 27, 2020 11:40:20 PM by  chaissos (0) 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.