What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

Creating a Report with Only Business Hours

Votes:

0

Your Vote:

Up

Down

Dear,

I saw many posts in this forum reporting problems while trying to generate specific reports in PRTG and none of them help me out to solved the following issue.

I'm not different than the others and I am trying to automate a report with specific hours (from 8am to 6pm), during specific period of time (a month, for example), but when PRTG sends the email with the report it shows 24 hours of the day.

I tried to check it by running a standalone report, with the same specifications (created before on Setup > Account Settings > Schedules), by it shows the same information with the 24 hour.

I just need your assistance in that case because we have to send this report to the board.

Best Regards,

Marcelo Simoes

prtg report sensor

Created on Dec 2, 2020 8:25:55 PM by  msimoesh (0) 1



6 Replies

Votes:

0

Your Vote:

Up

Down

Hi Marcelo,

I tried to create a report which displays only data between 8AM and 6PM each day for one month and everything worked as expected. Therefore I used the latest PRTG version. In the report, I configured a schedule in the option "Report Only for Specific Hours of the Day". The schedule has only active slots for the required time. As template, I used "Graph only" and "Graph and Table".

Created on Dec 3, 2020 8:36:11 AM by  Moritz Heller [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Dear Moritz,

I appreciated your return.

I'll check that options out and let you know the outcome.

Best Regards.

Created on Dec 4, 2020 3:35:55 PM by  msimoesh (0) 1



Votes:

0

Your Vote:

Up

Down

Hi Moritz,

Sorry about the delay of my answer. I checked the settings and the only difference betweeen your parameters and mine is I used the Template "List of sensors (no graphs), because we just need the uptime information. I also used the option "Report Only for Specific Hours of the Day" which we created a specific beginning and ending business hour.

Our version of PRTG is 20.2.59.1689+.

Created on Dec 15, 2020 5:03:15 PM by  msimoesh (0) 1



Votes:

0

Your Vote:

Up

Down

Hi Marcelo,

I checked the template which you use and the schedule works also there. This is displayed on the title of your report. After the period information you should see the same of your schedule or "24/7" if none is selected.
The effect of the schedule is difficult to see. You need to check the time in days, hours, minutes, seconds displayed in the list. This value depends on the schedule.
During my test:

  • With schedule around 10h uptime
  • Without schedule around 6d uptime

If this is not the case in your installation, I recommend to update to the lastest version.

Created on Dec 16, 2020 9:10:40 AM by  Moritz Heller [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Dear Moritz,

I think I understand the PRTG schedule. It works adding the time and showing it as a one huge time.

For example, in our case our report show "9d". For me it means 11 hours per day, plus 20 business day per day, split by 24 hours to result in days again means an amount of around 9 days. It is a little confuse by PRTG software.

I also noticed that PRTG works with an scheduled considering the hour that you mark with an entire hour. For instance, when we check the 06:00pm box while setting up a specific schedule, in the option "Setup/Account Settings/Schedule", it means to PRTG include the entire 06:00pm hour in the report, from 06:00pm to 07:00pm, caracterizing an hour out of our business hours and changing the real information of our report when we initiate any maintenance at 06:00pm.

I changed the schedule report stop the clock to 05:00pm (means from 05:00pm to 06:00pm) and it worked like a charm!

Thank you very much for your time, attention and guidance.

Best Regards,

Marcelo Simoes.

Created on Dec 16, 2020 12:35:28 PM by  msimoesh (0) 1



Votes:

0

Your Vote:

Up

Down

Hi Marcelo,

Thank you for the nice feedback.


I'm glad that the report works now as expecte.

Have a nice day!
/Moritz

Created on Dec 17, 2020 8:35:58 AM by  Moritz Heller [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.