What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

SNMP Datatype: SNMP_EXCEPTION_NOSUCHINSTANCE while loading 3rd party MIB




I am trying to add a new sensor to PRTG to monitor zscaler server.
I have copied the MIB file to PRTG managed server and configured SNMP to load the file.

When i run a SNMP tester in PRTG I get the below error:

----------------------- New Test -----------------------
Paessler SNMP Tester - 20.2.4 Computername: DEVICENAME Interface: (x.x.x.x)
27/05/2021 08:29:09 (2 ms) : Device: x.x.x.x
27/05/2021 08:29:09 (5 ms) : SNMP v2c
27/05/2021 08:29:09 (7 ms) : Custom OID
27/05/2021 08:29:09 (15 ms) : SNMP Datatype: SNMP_EXCEPTION_NOSUCHOBJECT
27/05/2021 08:29:09 (18 ms) : -------
27/05/2021 08:29:09 (20 ms) : Value: #N SNMP_EXCEPTION_NOSUCHOBJECT222
27/05/2021 08:29:09 (22 ms) : Done

I have tried a walk from SNMP Tester and get no response.

----------------------- New Test -----------------------
Paessler SNMP Tester - 20.2.4 Computername: DEVICENAME Interface: (x.x.x.x)
27/05/2021 08:29:48 (2 ms) : Device: x.x.x.x
27/05/2021 08:29:48 (5 ms) : SNMP v2c
27/05/2021 08:29:48 (7 ms) : Walk

On the SNMP agent server i get the below error:
snmpwalk -v2c -Ir -c arlsnmp x.x.x.x
ZSCALER-PROCESSHEALTH-MIB::processhealthTable = No Such Object available on this agent at this OID

My Linux Centos 7 server has SNMP v1 and v2c enabled and running. There is no firewall running on the server.
The server are behind proxy.
The servers are being monitored by PRTG but the need to add a new sensor.

I need to know where should i load the MIB file : PRTG SERVER or the Managed Device. And where did i go wrong here?

nosuchobject222 snmp-exception-nosuchobject zscaler

Created on May 31, 2021 6:45:06 AM

Last change on Jun 3, 2021 6:44:41 AM by  Timo Dambach [Paessler Support]

1 Reply




In general you need to load the oidlib file (converted MIB file) to the PRTG Probe server in order to add the SNMP Library sensor.

However the "No such object" error means that the specified SNMP object couldn't be found and the target device isn't returning any values. Are you sure the mib file fits your device?

Created on Jun 3, 2021 6:49:00 AM by  Timo Dambach [Paessler Support]

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.