What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

Can't Get WMI to Work

Votes:

0

Your Vote:

Up

Down

End goal, I have 2 application services (installed by the application) that I need to monitor to make sure they are running and alert me if they are not.

I have tried everything I know to do and I either get a message from PRTG that the account does not have access or that RPC is unavailable.

The server I am wanting to monitor the Services on is not on a domain. It is a standalone server. The same goes for the PRTG server.

- Both servers are running Server 2019 Standard.
- Both server have the same local account and password, which I created just for this access.
- This local account is a member of the DCOM, Performance Monitoring, and Remote Desktop groups on the local servers.
- I have gone through the DCOM configuration tool (dcomcnfg) and given the DCOM and Performance Monitoring groups all the access it needs, along with adding the local user account and doing the same thing.
- I have tested that the server I want to monitor is listening and answers on port TCP 135.
- I have disabled the Windows Firewall and turned of the AV software, on both servers.
- I have added the ports 49152-65535 and 1024-5000 to the range of ports that DCOM should listen on, again on both servers.

I am pretty sure most, if not all, of this only needs to be done on the server I want to monitor the services on, but I did it on the PRTG server as well after I was not getting any success.

Not sure where else to look or what else to do. Any help would be appreciated.

prtg rpc wmi

Created on Nov 12, 2021 8:28:06 PM by  mtlscott (0) 1

Last change on Nov 15, 2021 7:24:24 AM by  Felix Wiesneth [Paessler Support]



3 Replies

Votes:

0

Your Vote:

Up

Down

Hello there,

Thanks for the KB Post.

Did you try to add the user to the Local Administrators group as stated in this KB Article?

I would advise you to go through the requirement again if you have not.

If you have more questions, please let me know. Thanks!


With kind regards,
Chan Siau Hen
Technical Support Team, Paessler AG

Created on Nov 18, 2021 2:55:10 AM by  Chan Siau Hen [Paessler Technical Support]



Votes:

0

Your Vote:

Up

Down

Yes, the local account is a member of the local Administrators group.

Created on Nov 18, 2021 3:21:11 AM by  mtlscott (0) 1



Votes:

0

Your Vote:

Up

Down

Hi Scott,

As communicated, we will handle this issue via email. Thanks!


With kind regards,
Chan Siau Hen
Technical Support Team, Paessler AG

Created on Nov 23, 2021 6:02:11 PM by  Chan Siau Hen [Paessler Technical Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.