What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

Custom template for Rest Custom Sensor not working anymore



Since a few weeks my template "allnet.template" I am using to monitor my temperature sensors does not work anymore with the PRTG Rest Custom Sensor.

The current one gives an error: Could not create channel Berlin hpa: expected number but got error (string).

Does anyone have an advice how I can solve it? Here is the contents of the template file:

            "value":{$[#0].name : $[*].value

allnet custom prtg rest sensor

Created on Dec 3, 2021 9:31:47 AM

Last change on Dec 3, 2021 1:53:12 PM by  Florian Lesage [Paessler Support]

1 Reply




Thank you for your message.

To investigate on the origin of the issue, can you please enable the logs of the sensor by selecting the option Store result in its settings tab and then wait until the next interval for PRTG to generate them.

Afterwards, you should find the log files under [data path]\Logs\sensors where the data path is displayed in PRTG Administration Tool on the probe server.

I also invite you to execute the request manually with the same parameters as defined in the settings and check the response provided by the target device. For example, the latter could have been changed with an update and therefore do not match the template used anymore.


Created on Dec 6, 2021 6:41:44 AM by  Florian Lesage [Paessler Support]

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.