What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

IMAP Roundtrip - Helo command rejected: need fully-qualified hostname

Votes:

0

Your Vote:

Up

Down

Hi, After upgrading to PRTG Network Monitor 22.3.78.1873 my IMAP Roundtrip sensor fails during SMTP with the "Helo command rejected: need fully-qualified hostname" message. The host sending the email has an FQDN setup in Windows settings. Also I have on the sensors settings the "HELO Ident" setup correctly. However when the agent connects it uses the hostname alone without the domain name, ignoring system and sensors settings. How can I resolve this?

fqdn imap-rountrip smtp

Created on Sep 10, 2022 12:35:35 PM by  chanas (0) 1



3 Replies

Votes:

0

Your Vote:

Up

Down

We did not change anything directly on the sensor or the mail dispatch, but on the startTLS. Can you please check if the sensor settings match the change? Check the sensor manual for details on the TLS setting https://www.paessler.com/manuals/prtg/smtp_imap_round_trip_sensor

If not, you can open a support ticket at [email protected]

Created on Sep 15, 2022 7:32:21 AM by  Jonathan Mena [Paessler Technical Support]



Votes:

0

Your Vote:

Up

Down

Setting on sensor are like this: https://i.postimg.cc/B6xnV70Q/imap.png

When executing I get this on postfix logs:

postfix/smtpd[188989]: connect from mx.lighthouse.gr[5.133.183.81]
postfix/smtpd[188989]: Anonymous TLS connection established from mx.lighthouse.gr[5.133.183.81]: TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
postfix/smtpd[188989]: NOQUEUE: reject: RCPT from mx.lighthouse.gr[5.133.183.81]: 504 5.5.2 <cronus>: Helo command rejected: need fully-qualified hostname; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<cronus>
postfix/smtpd[188989]: lost connection after RSET from mx.lighthouse.gr[5.133.183.81]
postfix/smtpd[188989]: disconnect from mx.lighthouse.gr[5.133.183.81] ehlo=2 starttls=1 mail=1 rcpt=0/1 rset=2 commands=6/7

Also email headers are:

Received: from cronus (cronus [5.133.183.81])
     (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits))

So HELO is not FQDN. I removed the fqdn check for this host on postfix and message comes through.

Created on Sep 15, 2022 10:43:04 AM by  chanas (0) 1

Last change on Sep 15, 2022 1:59:50 PM by  Felix Wiesneth [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Thank you for that information I'm glad it works. Usually HELO needs to be the DNS name of the PRTG server.

Created on Sep 19, 2022 10:46:47 PM by  Jonathan Mena [Paessler Technical Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.