What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

How to solve vulnerability CVE-2016-7103, CVE--2015-9251 on PRTG 22.4.81.1532

Votes:

0

Your Vote:

Up

Down

Would like to know if the vulnerability is detected as mentioned above, how am I able to solve it?

  • The CVE-2016-7103 is about the cross scripting vulnerability in jquery UI ver 1.10.3. I have downloaded the latest jquery but where should I put these file?
  • The CVE-2015-9251 is about the cross scripting vulnerability in jquery ver 1.11.1.Are they able to solve if the jquery is updated?

jquery prtg vulnerability

Created on Jan 16, 2023 7:04:40 AM by  kcwong819 (0) 1

Last change on Jan 20, 2023 3:28:34 PM by  Moritz Heller [Paessler Support]



1 Reply

Votes:

0

Your Vote:

Up

Down

Hi there,

The old jQuery version is a known issue. We are currently in the process to rewrite the whole UI Client and will therefore not patch the framework version here, unless a critical vulnerability that is applicable to PRTG comes up. The known vulnerabilities for the Version in question do not apply to PRTG

Created on Jan 20, 2023 3:29:38 PM by  Moritz Heller [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.