What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general.

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
More than 500,000 users rely on Paessler PRTG every day. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags

View all Tags

Active Directory Replication Errors sensor not working since update to



I am now receiving access has been denied.

access-issues active-directory replication-check sensor

Created on Feb 15, 2023 5:44:02 PM

6 Replies



Do you use a user with restricted permissions? If you created such a user with access to the cimv2 namespace, please be advised that this sensor needs access to the MicrosoftActiveDirectory namespace as well. ​ Please check the permissions and test with a domain administrator account to verify the general function.

Replication Access is a security setting that has to be enabled for the user whose credentials are used when running the sensor.

To enable this setting, please follow the steps below: 1. Open the Active Directory Users and Computers snap-in

2. On the View menu, click Advanced Features.

3. Right-click the domain object, such as "mydomain.com", and then click Properties.

4. On the Security tab, select the account of the user whose credentials are used to run the sensor. (or add it if it does not exist here)

5. Click to select the Monitor Active Directory Replication check box from the list.

6. Click Apply, and then click OK.

If it is still not working we recommend to open a ticket at [email protected]

Created on Feb 21, 2023 5:01:09 AM by  Jonathan Mena [Paessler Technical Support]



Just update to and also got error. Tried to remove and add again. I got this error when I add the sensor : Impossible to create Active Directory replication errors: Exception not manage : System.ArgumentNullException: Array cannot be null. at PTF.#=qqPDcqsy$HkoV_yyPVmH9xeVNCfU1Cod0TpDcpk13oN4=.#=qF7CDCYQJuIiQ83F8p2cBuA==() à PTF.#=qsAzqb$yF67ZgKJq5S0wODpMghj4gmXImq6_znRAlgxE=.#=q7ozqM7nm5VZI3Wm82jwCEA==()

Created on Feb 28, 2023 4:25:15 AM



There were indeed changes in version 82 regarding the AD Replication Sensor to improve its security (password transmission). Internally we did not encounter any issues with this change, however, it seems like there might be configurations that have issues with this change for some reason.

We are investigating if this could be an actual problem. Are you using any Antivirus software? For testing purposes please ensure that no antivirus software or firewall is interfering with PRTG. Check if both PRTG folders (Data - "C:\ProgramData\Paessler\PRTG Network Monitor\" and System - "C:\Program Files (x86)\PRTG Network Monitor\") are whitelisted recursively within the application if any is installed.

Some customer reported their antivirus blocking the PRTG services and causing issues like this.

Created on Mar 1, 2023 4:59:52 AM by  Jonathan Mena [Paessler Technical Support]



I have got the same problems, but only Domain type sensor have problems, all other 4 works (Configuration, Schema, DomainDnsZones and ForestDnsZones).

Created on Mar 1, 2023 1:00:48 PM



No antivirus and Monitor Active Directory Replication permission ok. The strange is that only Schema istance stop working.

Created on Mar 2, 2023 6:12:26 PM



In this case we recommend to contact us through a support ticket to get more details, you can send an email to [email protected]

Created on Mar 7, 2023 3:56:30 AM by  Jonathan Mena [Paessler Technical Support]

Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.