New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Unable to get Remote Probe Working

Votes:

0

Your Vote:

Up

Down

I have successfully installed a remote probe on a different machine, that is on the same LAN as the core server. Although I have proved comm's between the machines I cannot get the remote probe to appear on the server.

A Wireshark trace shows that the probe is sending requests to the right port number and is getting a response from the server.

The event log for the remote probe shows multiple entries with the same two messages: "Need login" "Connected" "Need login" "Connected" etc

I have checked that the access keys match, so I cannot workout what this "Need login" reference is referring to.

Can you tell me where I'm going wrong, or what else I need to do to get the server to accept the remote probe.

install probe remote

Created on Sep 23, 2010 3:21:07 PM by  Westermo (1) 1



Best Answer

Accepted Answer

Votes:

1

Your Vote:

Up

Down

If you have problems with the setup of remote probes, please refer to PRTG Manual: Debugging Probe Connection Problems.

Created on Mar 25, 2013 12:22:10 PM by  Gerald Schoch [Paessler Support]

Last change on May 31, 2019 9:51:17 AM by  Felix Saure [Paessler Support]



14 Replies

Votes:

0

Your Vote:

Up

Down

Hello,

which exact version of PRTG are you using?

Best Regards.

Created on Sep 23, 2010 6:02:06 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I have a trial version of 8.1.0.1607 installed.

Created on Sep 24, 2010 7:04:59 AM by  Westermo (1) 1



Votes:

0

Your Vote:

Up

Down

Hello,

please check if the remote-probe is also on this version (or if it might needs to be updated). Please furthermore, try if restarting the probe service does help.

Best Regards.

Created on Sep 24, 2010 4:28:57 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi, I have exactly the same issue Westermo. Both the server and remote probe are using 8.1.0.1607 trail so I can test this new version before purchase. I'm using the default ports for the remote probe and infact I successfully used remote probes in V7.3 about a month ago without any issues. I can see the traffic coming through the firewall but the RRTG server just does not process/acknowledge the remote probe request in any of it's log files.

Please let me know if you have any ideas.

Thanks......Paul.

Created on Sep 30, 2010 4:11:27 PM by  Pscahill (0)



Votes:

0

Your Vote:

Up

Down

Hello,

can you please try if the issue persists with the newest build of PRTG (8.1.0.1627)?

Best Regards.

Created on Sep 30, 2010 5:41:40 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi This upgrade didn't fix it or shed any light on it but after going through the settings again I managed to find the setting. I had setup the server to accept any IP in the setup/probe section within the web interface but I hadn't noticed the setting in the server administrator tool. In the sever admin tool I had to allow remote probes to connect to the server in the core server tab.

It is a bit confusing having the similar settings in two places and it would be better if the remote probe gave a better error message eg. server is not configured to accept remote probe requests.

Anyway fixed now so testing is underway, Many Thanks.......Paul.

Created on Oct 1, 2010 11:40:22 AM by  Pscahill (0)



Votes:

0

Your Vote:

Up

Down

Same problem with my trial installation. The Firewall logs the traffic between the remote probe and the core server. The logfile of the probe states "Need Login" but the Access Keys are copy pated from the core servers Webgui. PRTG Version is 8.1.0.1627. The Version of the Probe is the same. Some error or mistake on my side possible or it´s a bug in the 8.1... builds?

Regards Marcus Esposito

Created on Oct 10, 2010 3:11:50 PM by  esposito (0)



Votes:

0

Your Vote:

Up

Down

Hello,

so far we are not aware of any general problem with the Remote Probes in version 8.1 of PRTG. Can you please re-check all the necessary settings (PRTG Server Admin on the Core Server; PRTG Probe Admin on the Remote Probe Machine; and especially the settings in the webinterface in "Setup"->"System Administration"->"Probes" in terms of the Allow and Deny IPs lists).

Best Regards.

Created on Oct 12, 2010 3:15:23 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi!

I get the same thing on my 8.1.0.1628 installation. I upgraded two days ago from version 7.3.5.5747.

After upgrade my two remote probes worked as expected but one of them stopped working today. In the log I see the following;

2010-10-15 12:33:55 Connection: Access violation at address 6B0A25FB in module 'ssleay32.dll'. Read of address 000000FC (State=9) (State=9)
2010-10-15 12:34:07 Create new Connection2010-10-15 12:34:12 Disconnected from 10.12.42.27:23560
2010-10-15 12:34:38 Socket Error # 10060  Connection timed out. (will keep trying)
2010-10-15 12:34:49 Create new Connection
2010-10-15 12:35:27 Time change. System: 2010-10-15 12:35:27 PRTG (UTC): 2010-10-15 10:35:27 PRTG (Local Timezone): 2010-10-15 12:35:27
2010-10-15 12:35:31 Create new Connection
2010-10-15 12:36:14 Create new Connection
2010-10-15 12:36:57 Create new Connection
2010-10-15 12:37:39 Create new Connection

Then when I tried to stop/start the probe service I see the following in the log:

2010-10-15 14:51:19 SSL Enabled
2010-10-15 14:51:19 Probe GID: {B4CEE2EC-C16E-49A0-90EA-D16CBB63FC48}
2010-10-15 14:51:20 Need Login
2010-10-15 14:51:21 Need Login

Not sure what might have caused this. Now I can't get the probe to work.

Any ideas? Need to get my installation running again. Where do I open a case for this.

Jesper Boll Entraction

Created on Oct 15, 2010 1:13:33 PM by  Jesper Boll (0)

Last change on Oct 18, 2010 12:41:35 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Dear Jesper,

you can open a support ticket, right directly from within PRTG in the Help-Section. Otherwise, have you checked all the necessary settings already (especially the settings in the webinterface in "Setup"->"System Administration"->"Probes" in terms of the Allow and Deny IPs lists)? In most cases it was just something forgotten to enter or a typo.

Best Regards.

Created on Oct 18, 2010 12:43:04 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I am also having the same issue. The local probe works fine, but the remote probe log file is giving me the following:

10/22/2010 10:39:50 AM Need Login

10/22/2010 10:39:50 AM 40 connection attempts failed with error Socket Error # 10061 Connection refused. (will keep trying)

Created on Oct 22, 2010 2:46:56 PM by  Jeff Kling (0) 1



Votes:

0

Your Vote:

Up

Down

"Socket Error # 10061 Connection refused. (will keep trying)" suggests that either there is a firewall between remote probe and core server which blocks the communication, or that the Core Server still might be set to only accept Local Probe connections.

Created on Oct 22, 2010 3:18:42 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

After you set up the remote probe, did you "approve" it inside the core server admin?

Created on Jan 3, 2011 10:16:55 PM by  jared (0) 1



Accepted Answer

Votes:

1

Your Vote:

Up

Down

If you have problems with the setup of remote probes, please refer to PRTG Manual: Debugging Probe Connection Problems.

Created on Mar 25, 2013 12:22:10 PM by  Gerald Schoch [Paessler Support]

Last change on May 31, 2019 9:51:17 AM by  Felix Saure [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.