New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


Icons change with discovery trough templates

Votes:

0

Your Vote:

Up

Down

Hey,

I've got a problem. A very silly one. I'd like to have different icons for different devices. Adding a device with an icon other than the default one is no problem, however a problem occurs when adding sensors to that device using a template. The chosen icon stays untill the device is done auto-discovering the sensors described in the template. After the discovery the icon changes to something PRTG chose itself.

It's a stupid problem, with absolutely no priority, but i'd still like to know if there is a fix ;)

auto-discovery icons prtg template

Created on May 11, 2015 2:14:07 PM by  Echelon (0) 2 1



11 Replies

Votes:

0

Your Vote:

Up

Down

We couldn't reproduce that behavior. Could you upload the template somewhere so we can have a look at it?

Created on May 12, 2015 1:32:31 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Here it is: http://we.tl/aUwtsQdqL3 I believe it's about the same as the default template van a RD Server. However the problem occurs with every template i choose and seemingly only when the device is running on a VMWare ESX server (The icon then changes to the "C_OS_VMware" icon).

Edit: It happens when a vendor is detected. After the discovery it gets the vendor's icon.

Created on May 13, 2015 7:21:58 AM by  Echelon (0) 2 1

Last change on May 13, 2015 1:25:52 PM by  Arne Seifert [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Ah, that explains it - so, problem solved? :)

Created on May 15, 2015 8:00:21 AM by  Stephan Linke [Paessler Support]

Last change on May 15, 2015 8:00:29 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

unfortunately not, i found the cause but no solution. I tried to delete the entries in 'Deviceiconlist.txt' file, where it kept locations of the icons for all vendors, but that didn't change anything.

I don't know if this is a bug in PRTG or just something wrong with my specific installation.

Created on May 15, 2015 8:04:05 AM by  Echelon (0) 2 1



Votes:

0

Your Vote:

Up

Down

Have you tried to restart your PRTG server after deleting the list? :)

Created on May 19, 2015 8:03:05 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hello I have the same problem I have added a Raspberry icon in devices vendors and made a template from an object with this icon When running auto discovery objects are created with a default icon instead of the raspberry I have read the odt file but cannot find anything related to this icon Prtg version is 18.1.37.12158 What should I do to have this icon assigned to new objects from this template?

Created on Feb 28, 2018 10:02:37 PM by  dgiraud (0) 1



Votes:

0

Your Vote:

Up

Down

Hi dgiraud,

Does this apply to existing devices as well? Like, are their icons overwritten?


Kind regards,
Stephan Linke, Tech Support Team

Created on Mar 1, 2018 8:49:02 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi Stephan Actually I did not test on already existing devices as I unchecked "Discover existing devices" (or st like that) Could my sending the template be useful?

Created on Mar 1, 2018 10:32:01 AM by  dgiraud (0) 1



Votes:

0

Your Vote:

Up

Down

Seemingly, you can't configure icons in the device templates. Just use Devices | Device List and multi edit the devices. You can configure the icon for multiple devices at once with this :)

edit It works, see my follow up post


Kind regards,
Stephan Linke, Tech Support Team

Created on Mar 1, 2018 11:02:22 AM by  Stephan Linke [Paessler Support]

Last change on Mar 1, 2018 12:50:03 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Thank you :( It's sad

Created on Mar 1, 2018 12:13:28 PM by  dgiraud (0) 1



Votes:

0

Your Vote:

Up

Down

Hi,

Sorry, my bad - it's indeed possible. Simply edit the device template and modify the device tag to include the deviceicon attribute, like shown in the following example:

<devicetemplate id="arubaaiap" name="Aruba_AIAP" priority="1"  deviceicon="vendors_Aruba.png">

Kind regards,
Stephan Linke, Tech Support Team

Created on Mar 1, 2018 12:46:53 PM by  Stephan Linke [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.