What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

PRTG Network Monitor

Intuitive to Use. Easy to manage.
300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free Download

Top Tags


View all Tags

"Failed to establish secure connection" on SSL Certificate Sensor Beta

Votes:

0

Your Vote:

Up

Down

I've tried to setup the SSL Certificate Sensor Beta on our PRTG Server, and all i'm getting is Failed to establish secure connection [Step 0] Socket Error #10051... repeated few times for step 1,2,3,4.

If i understood correctly, I have to define a Device which contain the URL to monitor (ex: www.mydomain.com). So in my device at field IPv4 Address/DNS Name, i've written www.mydomain.com.

Our server doesn't use SNI. We have several domain pointing to it, but they all got their public IP. So in my sensor, i've left the field Virtual Host (SNI Domain) empty. We have 2 domains with wildcards on this server, does it make any difference? Should i write mydomain.com instead of www.mydomain.com?

Does anyone can tell me where i got this wrong and how i can solve this problem?

I had no problem using the previous sensor which is now deprecated, but this one is giving me a hard time.

Thanks for your help

http-ssl-certificate-expiry ssl ssl-certificate

Created on Jul 27, 2016 9:19:45 PM by  cdebel2005 (10) 1



12 Replies

Votes:

0

Your Vote:

Up

Down

Hello,

Thank you very much for your KB-Post. Can you provide some screenshots showing the exact URLs/IPs entered both in the Sensor and device settings?

Thank you!

Created on Jul 29, 2016 10:31:48 AM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

DEVICE SETTING

Device Setup

SENSOR SETTING

SensorSetup

RESULT

SensorSetup

Thank you

Created on Jul 29, 2016 1:38:05 PM by  cdebel2005 (10) 1



Votes:

0

Your Vote:

Up

Down

Can you please try, if adding a

https://

in front of the URL makes a difference?

Created on Aug 1, 2016 8:28:13 AM by  Torsten Lindner [Paessler Support]

Last change on Aug 1, 2016 8:29:54 AM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

just tried with "https://" in front of it (in Device, and also in Sensor), same result.

Created on Aug 1, 2016 6:49:48 PM by  cdebel2005 (10) 1



Votes:

0

Your Vote:

Up

Down

This is quite strange. It does work for me here with directly www.mybys.com: https://abload.de/img/device2devicepmol6p.png

Could a firewall or something be blocking here in your case?

Created on Aug 2, 2016 8:46:06 AM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Which version of PRTG are you using? I'm using 16.121.1924. I'll upgrade to the lastest tonight to see if it solve the problem.

As for the firewall issue, i can't see what could be the issue since on the Server where PRTG Core is installed, i open the browser and access our web site thru https and i have no problem. Port 80 & 443 are opened.

Created on Aug 2, 2016 6:28:28 PM by  cdebel2005 (10) 1



Votes:

0

Your Vote:

Up

Down

Okay, the version is indeed a difference here, as I was testing it on the latest Preview build.
Do you have a proxy server running, which may also be an issue here?

Created on Aug 3, 2016 6:56:25 AM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I've just updated to the latest version, and i still have the same problem.

We don't have a proxy, but this server has 2 network card (one for our lan, one for internet). All the devices are set to use LAN IP's except this SSL Certificate which use the domain name. Windows Firewall is turned off, and our provider Firewall is on but as i've said, port 80 and 443 are not blocked.

I've just installed PRTG at home to monitor this SSL Certificate and it work perfectly, so there must be something with this installation, Or this network. So I'll try to install it on another computer on this LAN which is similar to this one, and see if its caused by the network or by an update which gone wrong.

Created on Aug 3, 2016 7:59:36 AM by  cdebel2005 (10) 1



Votes:

0

Your Vote:

Up

Down

Please also check if the Probe Setting for Monitoring Requests is set to Auto on the 'problematic' Probe. That may help as well.

Created on Aug 4, 2016 7:04:06 AM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Sorry for the long time, i was on vacation.

I think you nailed it. I see that on IPv4 its not set to auto, but a specific IP on our LAN.

Created on Aug 17, 2016 2:30:46 PM by  cdebel2005 (10) 1



Votes:

0

Your Vote:

Up

Down

Does it work when switched to "Auto" then?

Created on Aug 18, 2016 7:52:11 AM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Yes it work, thanks

Created on Aug 26, 2016 6:01:19 PM by  cdebel2005 (10) 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.