New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

200.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


How to add a sub group only for reporting

Votes:

0

Your Vote:

Up

Down

Hi,

Hoping for some help here please!

When I run a report, I add the sensor I want in the settings Eg. Ping Now when I go to "select sensor manually", I only want to do a report on a sub group which I drag over to the left hand side.

But the final report produced includes the everything from the root.

How do I get the sub group and devices only?

Hope this makes sense

Thank you Rob

devices reports sub-group-only

Created on Jan 14, 2019 5:28:54 PM by  Vambo (0) 1



Best Answer

Accepted Answer

Votes:

1

Your Vote:

Up

Down

You can create your own template by simply copying the following files in C:\Program Files (x86)\PRTG Network Monitor\webroot\reporttemplates\ (and renaming them accordingly):

  1. T3 Top100 Uptime time.htm
  2. \details\Stats Loop 100 Up Time.htm

Just rename the template in the first line (the one that is commented out):

<!--Top 1000 Uptime/Downtime (Data Files Not Available): Top 1000 Uptime/Downtime (based on uptime hours)-->

...and within the Stats Loop custom File, there are two count attributes, set to 100. Increase them to your needs, restart the PRTG Core Server and you should be able to create the report with more sensors :)


PRTG Scheduler | PRTGapi | Feature Requests | WMI Issues | SNMP Issues

Kind regards,
Stephan Linke, Tech Support Team

Created on Jan 16, 2019 12:58:25 PM by  Stephan Linke [Paessler Support]

Last change on Jan 16, 2019 12:58:31 PM by  Stephan Linke [Paessler Support]



11 Replies

Votes:

0

Your Vote:

Up

Down

Does the "Add Sensors Manually" only include the sensors you like? When you go to settings, are there any tags in "Include Sensors By Tag"?


PRTG Scheduler | PRTGapi | Feature Requests | WMI Issues | SNMP Issues

Kind regards,
Stephan Linke, Tech Support Team

Created on Jan 15, 2019 12:14:11 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi Stephen

I have added the "ping sensor" into add sensors by tag.

Hopefully I have explained my problem correctly? I have several hundred remote sites/devices broken down into sub categories (groups)

When I drag a group over and run a report it ends up including the whole tree and not just the group I want.

I'm happy to send a screenshot if this would help.

Thank you Rob

Created on Jan 15, 2019 12:50:56 PM by  Vambo (0) 1



Votes:

0

Your Vote:

Up

Down

That would indeed help :) Especially the "Add Sensors manually" tab as well as the "Sensors Selected by Tag" tab :)


PRTG Scheduler | PRTGapi | Feature Requests | WMI Issues | SNMP Issues

Kind regards,
Stephan Linke, Tech Support Team

Created on Jan 15, 2019 1:28:46 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi Stephen

I can't seem to add a screenshot on this forum. Does it allow for attachments or is there an alternative address I can get this to you?

Thanks rob

Created on Jan 15, 2019 1:34:16 PM by  Vambo (0) 1



Votes:

0

Your Vote:

Up

Down

You can use an image hoster of your choice and the direct image URL with the following markup:

{{url to your image|title}}

PRTG Scheduler | PRTGapi | Feature Requests | WMI Issues | SNMP Issues

Kind regards,
Stephan Linke, Tech Support Team

Created on Jan 15, 2019 1:39:15 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

The first screenshot is empty :( I think it's probably better to open up a support case via [email protected] and provide screenshots within the mail :)


PRTG Scheduler | PRTGapi | Feature Requests | WMI Issues | SNMP Issues

Kind regards,
Stephan Linke, Tech Support Team

Created on Jan 15, 2019 4:01:54 PM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi Stephen

I've checked the links.

http://i66.tinypic.com/6qebty.jpg

http://i66.tinypic.com/2hej9f7.jpg

Both images show after pasting the links into my web browser.

Could you try once more for me please?

Thank you Rob

Created on Jan 15, 2019 4:09:42 PM by  Vambo (0) 1



Votes:

2

Your Vote:

Up

Down

Yep, they work now. Could you remove the tag in the pingsensor from "Include Sensors by Tag" and only work with the actual tree? Because if you add the tree manually, but keep the pingsensor in the tags, it will add these additionally to what has been added manually :)


PRTG Scheduler | PRTGapi | Feature Requests | WMI Issues | SNMP Issues

Kind regards,
Stephan Linke, Tech Support Team

Created on Jan 16, 2019 7:28:27 AM by  Stephan Linke [Paessler Support]

Last change on Jan 16, 2019 7:28:40 AM by  Stephan Linke [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Hi Stephen

Worked a treat.

Many many thanks

Rob

Created on Jan 16, 2019 12:04:48 PM by  Vambo (0) 1



Votes:

0

Your Vote:

Up

Down

Hi Stephen

One last question (hopefully)

If I want to run a report that includes Eg. >100 devices/sensors, can I do this without using a template?

The templates seem to offer the whole scope or the top 100.

Thank you Rob

Created on Jan 16, 2019 12:51:20 PM by  Vambo (0) 1



Accepted Answer

Votes:

1

Your Vote:

Up

Down

You can create your own template by simply copying the following files in C:\Program Files (x86)\PRTG Network Monitor\webroot\reporttemplates\ (and renaming them accordingly):

  1. T3 Top100 Uptime time.htm
  2. \details\Stats Loop 100 Up Time.htm

Just rename the template in the first line (the one that is commented out):

<!--Top 1000 Uptime/Downtime (Data Files Not Available): Top 1000 Uptime/Downtime (based on uptime hours)-->

...and within the Stats Loop custom File, there are two count attributes, set to 100. Increase them to your needs, restart the PRTG Core Server and you should be able to create the report with more sensors :)


PRTG Scheduler | PRTGapi | Feature Requests | WMI Issues | SNMP Issues

Kind regards,
Stephan Linke, Tech Support Team

Created on Jan 16, 2019 12:58:25 PM by  Stephan Linke [Paessler Support]

Last change on Jan 16, 2019 12:58:31 PM by  Stephan Linke [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.