New Question
 
 
PRTG Network Monitor

Intuitive to Use.
Easy to manage.

300.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Free PRTG
Download >>

 

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

 

Top Tags


View all Tags


User Groups - Active Directory

Votes:

0

Your Vote:

Up

Down

Q1) Created user group and linked to AD. I get no errors, I can login with the credentials of the AD user. However, no matter what I do I see nothing when I log in. No groups , devices, sensors. I have setup the "Access Rights" on the groups, I can see its being inherited. I have even used the "Revert children's access rights to inherited" to force the child objects to inherit the rights. I have tried to setup the "Access Rights" manually on some sensors with the specific group the user is member of.

I still have no luck.

Q2) When using a group from AD that has a nested groups of users, is this going to work?

thanx Petr

PRTG ver.: 9.1.4.1840

active-directory groups user

Created on Jan 31, 2012 9:07:52 AM by  pettt (118) 1 1



6 Replies

Accepted Answer

Votes:

0

Your Vote:

Up

Down

Hello,

first of all, can you please update to the latest version (9.2) of PRTG, there were a few minor changes and fixes in the Active Directory integration since 9.1.4. Furthermore, when being logged in as "prtgadmin" please try a right-click on the objects the Active Directory User(s) should see and then go to "Edit"->"Access Rights", this will bring you to a page where you exactly see the rights (inherited and directly set) for the object and should shed light on any faults or missing settings.

best regards.

Created on Jan 31, 2012 5:18:43 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

I will try the upgrade and come back to update the info.

The second question remains. To my tests it appears that only groups with users directly inside are working. If the AD group has another group in it, the users from the sub-group have no access. Can you please confirm/deny this ?

Best Regards

Created on Feb 1, 2012 4:59:13 PM by  pettt (118) 1 1



Votes:

0

Your Vote:

Up

Down

Nested AD-Groups haven't been tested indeed I'm afraid, but this should then fail at the login already.

Created on Feb 2, 2012 2:31:02 PM by  Torsten Lindner [Paessler Support]



Votes:

0

Your Vote:

Up

Down

Well, The new release 9.2.0 fixed the problem with the objects not being visible. However, the fact remains that only users object directly existing in linked AD group are authorized access.

It appears nested groups are not supported. :O( I hope this is coming in the future, as in Enterprise environment it is practically impossible to exist without.

Thanx

Created on Feb 3, 2012 4:18:57 PM by  pettt (118) 1 1



Votes:

0

Your Vote:

Up

Down

hello Paessler Team,

Nested AD Groups does not seem to work. Still in latest Version 18. Are there any plans or will the authentication remain the same also for the next 10 Years?

Regards

Created on Jan 3, 2019 5:30:00 AM by  Michele Jetz (105) 1



Votes:

0

Your Vote:

Up

Down

Hello Michele,

Still no plans, we received such requests in the past as well, but all in all demand was not that high so far in order to consider it. Feel free to propose the feature as mentioned here.

Kind regards,

Erhard

Created on Jan 3, 2019 7:48:32 AM by  Erhard Mikulik [Paessler Support]



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.